CVWdocserver40 setup on Redhat 9

2003-11-13
2003-12-15
  • Umesh Balani

    Umesh Balani - 2003-11-13

    Hi,

    I am trying to run the "cvwds.boot" script
    on Redhat 9 box.

    The safe_mysqld script gives a segment fault.

    Any ideas, what am i doing worng ?
    Here's the log.

    [root@somebox mysql]# ./bin/safe_mysqld
    Starting mysqld daemon with databases from /var/lib/mysql
    + test 0 -eq 0
    + trap '' 1
    + exec nohup /opt/CVWdocserver40/mysql/bin/mysqld --basedir=/opt/CVWdocserver40/mysql --datadir=/var/lib/mysql --user=root --pid-file=/var/run/mysqld/mysqld.pid --skip-locking
    ./bin/safe_mysqld: line 198:  9202 Segmentation fault      ( trap "" 1; exec $NOHUP_NICENESS $ledir/mysqld $defaults --basedir=$MY_BASEDIR_VERSION --datadir=$DATADIR --user=$user --pid-file=$pid_file --skip-locking >>$err_log 2>&1 )
    + test '!' -f /var/run/mysqld/mysqld.pid
    + break

    There are two empty directories in my "/var/lib/mysql" i.e. mysql and test. I am wondering why is the script trying to access that folder.

    Regards
    Umesh

     
    • Anonymous - 2003-11-17

      I bypassed the problem updating the components.

      1. I installed jdk 1.4 (J2SE 1.4.2_01)
              to use it: export JAVA_HOME=/usr/java/jsdk1.4.2_01

      2. I installed new mysql (4.0.15)
              a new mysql need to run mysql_install_db from
          /opt/CVWdocserver/mysql but,
              to be sure that data go to the good place (for CVW),
              you must change /etc/my.cnf or not use it at all
              (as I did for the moment, changing the name for example)
              recreate the symbolic link
              Be sure to have the correct permisions

      3. I installed new Jakarta-Tomcat (4.1.27)
              recreate the symbolic link
              copy the application from the old Tomcat
              modify the port Tomcat is listening
              correct permisions

      Regards

      Carlos

       
    • Umesh Balani

      Umesh Balani - 2003-11-27

      hi Carlos,

      Please tell me your email ID.
      Do you want me to install the Mysql in the default location.
      Or your want me to replace the existing mysql db ?

       
    • Umesh Balani

      Umesh Balani - 2003-11-27

      Carlos,

      I am lost.

      I have installed the new mysql and the dameon is running.

      After this, I am really not sure what all scripts I need to change.

      I understand that I need to make the new mysql dameon run from the safe_mysqld script with the provied db in the docserver package. But its too complicated for me to fiddle with.

      Can you please help.

      Regards
      Umesh Balani

       
    • Anonymous - 2003-12-01

      At this moment I am not working with CVW because my CVW PC is broken, but:

      after installing java, mysql and Tomcat, with adecuate permisions,  you must control the startup script
           (/opt/CVWdocserver40/cvwds.boot).
      Normally it works without modifications, if CVWdocserver was installed in the default CVW directories.

      At this moment, from a terminal, as root, you can start CVWdocserver
          export JAVA_HOME=/usr/java/j2sdk1.4.2_01
          ....../cvwds.boot start
      and see the start messages for the
          docserver (mysql) and 
          webserver (Jakarta-Tomcat)

      If OK, you can connect from a browser to Tomcat default port
          http://yor_cvw_machine:8080
      and see the Tomcat's Welcome

      If OK, you can modify the port Tomcat is listen to 8889 in the config file
          ...../tomcat/conf/server.xml
          <Connector...port="8889" ..../> in non-SSL Coyote HTTP/1.1) ....
      and check again with the browser

      Try this and then we will continue

      Regards

      Carlos
         

       
    • Umesh Balani

      Umesh Balani - 2003-12-02

      Hi Carlos,

      I managed to make the whole thing run.
      Had to install a new mysql release and update the data file there.

      After that as u said i updated the cvwds.boot to
      not to fiddle with the mysql db as its already running.

      So the end deal is that everything is running, now i am trying to make the Multicast Video run .. then i get a "unable to set size in native format".

      Any ideas what this is about.

      Regards

       
    • Anonymous - 2003-12-03

      Hi Umesh,

      After you had running the cvwserver and cvwdocserver, I understand you installed the cvwclient. and you login.

      The cvwclient, has a configuration file (server.cvw) that I think you had configured (at least, cvw.server.host, cvw.docserver.host, cvwdocserver.url, cvwuserimages.url).

      I made the installation of the cvwclient on Windows 98 and ME, and VIC (original from LBL and replacement from UCL), worked (with a performance problem that I must solve).

      In which context did you have the problem?

      Regards

      Carlos

       
    • Anonymous - 2003-12-11

      Hi Carlos,

      The video problem also got solved by updating the vic.exe that comes by default in the setup with an updated one (replacement from UCL) as u said.

      Thanx for all the help dude.
      Everythings working neat.

      Okay .. here is an interesting problem.

      The Layer 3 switch between that conectes my subnet with other VLAN subnets in my network does not support Multicast Forwarding. Hence, only people from my vlan are able to recieve the mulitcast audio/video.

      Okay i read a lot about mrouted that lets to do IP-in-IP tunneling. You got your hands dirty with it.

      Apparently you setup a box in one VLAN and a box in another VLAN and setup up mrouted to make a IP tunnel.

      Any ideas how you do it ?

       
    • Anonymous - 2003-12-15

      Hi Umesh

      I do not have this situation, but, I understand that one machine in each subnetwork must be configured with mrouted to make the tunnel to propagate the multicast traffic encapsulated in IP traffic.
      In the CVW doc Multicast Installation Notes, there is an explanation.

      If you still have this problem, could be better to initiate or continue a thread of questions specific to the subject of mrouted configuration.

      Regards

      Carlos

       
    • Umesh Balani

      Umesh Balani - 2003-12-15

      Okay Carlos,

      I see your point.
      Will be starting another thread for this problem.

      Regards
      Umesh Balani

       

Log in to post a comment.