shinnok01 - 2005-03-08

hi,
I'm using Fedora Core 3 and downloaded patched cvs 1.11.18
I created a system account cvsroot and chown/chgrp/chmod as what it said on the patch's homepage.My repository is at /usr/cvs, and i have initialized it.
I modified aclconfig to:
UseCVSACL=yes
CVSACLDefaultPermissions=n
UseSystemGroups=no
UseCVSGroups=yes
CVSServerRunAsUser=cvsroot

Then I add a user "cvsadmin" into CVSROOT/passwd,when I tried "cvs -d /usr/cvs racl cvsadmin:p -d ALL"
it told me " cvs [racl aborted]: You do not have admin rights on ''      "
I modified "CVSACLDefaultPermissions=p" in aclconfig and tried the command again.It seems success,and the content of CVSROOT/access is "d:ALL:ALL:cvsadmin!p:" ,but when I change "CVSACLDefaultPermissions" back to "=n",all cvs racl operations failed with " cvs [racl aborted]: You do not have admin rights on ''      "
even with "CVSACLDefaultPermissions=p",I didn't think it works properly.Because when i run "cvs -d /cvs/usr racl -l -d ALL",the result is "d  | HEAD | | defaults ALL: p". I think cvsadmin should be output in the result.
Sorry for my bad English...Anyone can help me?I'll really appreciate...