Access denied with .netrc, works otherwise

Help
2007-07-01
2013-05-02
  • Florian Brucker

    Florian Brucker - 2007-07-01

    I'm having trouble mounting using the fstab/.netrc combination. If I use the normal command line interface it works fine:

    $ curlftpfs ftp://user:pass@server mountpoint

    I'm not sure where I have to keep my .netrc, but it doesn't work in the user home nor in the root home (I put the same file in both for testing). And I double-checked that the server/user/password settings are the same in the CLI parameters and .netrc/fstab. Any pointers on this are greatly appreciated!

    Regards,
    Torf

    $ ls -l ~/.netrc
    -rw------- 1 torf torf 59 Jul  1 14:23 /home/torf/.netrc

    $ cat ~/.netrc
    machine server
    login user
    password pass

    $ su -c "ls -l /root/.netrc"
    -rw------- 1 root root 59 Jul  1 14:25 /root/.netrc

    (Content of /root/.netrc is the same as in ~)

    $ grep curlftpfs /etc/fstab         
    curlftpfs#server  mountpoint    fuse    rw,uid=500,user,noauto  0 0

    $ su -c "lsmod | grep fuse"
    fuse                   39188  2

    $ mount mountpoint
    Error connecting to ftp: Access denied: 530

     
    • Robson Braga Araujo

      If you set it to noauto and don't mind typing your password every time, you can use "user=youruser":

      curlftpfs#server mountpoint fuse rw,uid=500,user,noauto,user=youruser 0 0

      It will ask for your password. Be aware that if try to mount it during boot, it will hang waiting for you to enter the password.

       
    • Florian Brucker

      Florian Brucker - 2007-07-02

      Using user=ftpusername in fstab works. I'd still prefer using .netrc, though. Is there a way to enable logging/verbose output when using fstab? Or do you got any other ideas on how to search for the error?

      BTW:

      $ curlftpfs -V
      curlftpfs 0.9.1 libcurl/7.16.3 fuse/2.5

       
      • Robson Braga Araujo

        The problem is that the mount script changes the user to your user but looks for the .netrc in $HOME, which still points to /root. I can add a parameter to curlftpfs to specify the .netrc, but you'd have to pointer to a specific directory, not a user dependent one.

         
        • Denis Golovan

          Denis Golovan - 2008-01-27

          >>The problem is that the mount script changes the user to your user but looks for the .netrc in $HOME, which still points to /root.

          Isn't that considered a bug? Are fuse devs aware of this feature/bug?

           

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks