#1095 Proxy feature version info wrong

closed-fixed
5
2013-06-21
2012-02-25
curlybugs
No

When working with enabling proxy support for a project, we were trying to ensure we documented which versions were needed for features correctly and found that there are conflicts over when features were introduced on these two pages:
http://curl.haxx.se/libcurl/c/curl_easy_setopt.html
http://curl.haxx.se/libcurl/c/symbols-in-versions.html

Under CURLOPT_PROXYTYPE in the setopt doc, it says that CURLPROXY_SOCKS4 was introduced in 7.15.2, whereas the symbols page reports 7.10. Since archived source bundles are difficult to come by, I can't confirm when it became available. Though I happened to have recently compiled software with socks support on a system running 7.15.1, so I know 7.15.2 is inaccurate.

Additionally, the setopt doc reports that CURLOPT_SOCKOPTFUNCTION was introduced in 7.15.6, but the symbols page says 7.16.

There may be other conflicts on the pages, but these are the ones we came across.

Discussion

  • Daniel Stenberg

    Daniel Stenberg - 2012-02-25
    • status: open --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks