I am trying to use curl-loader to perform a GET with a file upload but it keeps failing to send the filename.  I have attached the "PROBLEM-REPORTING" file with all the details as well as my conf file and the generated output files using the "-v -v -u -d" options.  Please advise how to proceed.

If you want the short version, this is the Description section from the "PROBLEM-REPORTING" file.

The command I run in curl works and is:

curl -X GET --connect-timeout 5 -m 600 -Y 200 -y 60 -F filename="@archives_x2cok01241201_.tar.gz" "http://172.17.0.150:8080/ckmp-ivc/IFEDataOffload?tailid=efxdom06281201&type=t&version=DL_X_FS_20120607&checksum=908022653&tailname=DL000"

However, when I try to use curl-loader to to the same thing, the server never sees the file attached.  curl-loader is currently found in:

# which curl-loader
/usr/bin/curl-loader

I have place copies of the "archives_x2cok01241201_.tar.gz" in /usr/bin as well as "/home/joseph9918/archives_x2cok01241201_.tar.gz" which is the same path where my get-ivc.conf file (posted inline above) is found.  I have tried using both the UPLOAD_FILE option and the MULTIPART_FORM_DATA option.  As a point of reference, when I use curl I get the following in wireshark:

13  2.567406    172.17.0.102    172.17.0.150    HTTP    GET /ckmp-ivc/IFEDataOffload?tailid=efxdom06281201&type=t&version=DL_X_FS_20120607&checksum=908022653&tailname=DL000 HTTP/1.1  (application/octet-stream)

Which tells me that curl attaches the filename correctly outside of curl-loader.  How can I make curl-loader perform the same request?  I am trying to load test a tomcat server which receives archives from multiple clients constantly.  The original author of the software implemented the software using a get with a file upload.  I understand that this is not considered HTTP spec but the software is already in the field so I have to work with it.  Please advise on how to proceed.


-- 
Joseph Ishak
Senior Systems Engineer
CoKinetic Systems Corporation
www.cokinetic.com

Recommendations are always appreciated.
http://www.linkedin.com/pub/joseph-ishak/3/915/31a