2.1-0 can't install (Linux)

Help
2008-01-18
2012-10-25
  • John Matthews

    John Matthews - 2008-01-18

    Hi- using 2.1-0, following the linux installation instructions in README, when I run autoconf I get:

    configure.in:4: error: possibly undefined macro: AM_INIT_AUTOMAKE
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    configure.in:58: error: possibly undefined macro: AM_CONDITIONAL
    configure.in:162: error: possibly undefined macro: AC_PROG_LIBTOOL
    configure.in:210: error: possibly undefined macro: AM_CONFIG_HEADER

    A configure file is generated, but if I run it I get:

    configure: line 1311: syntax error near unexpected token CUnit,' configure: line 1311:AM_INIT_AUTOMAKE(CUnit, 2.1-0)'

    Any ideas? I'm running CentOS 4 which (I believe) is basically Red Hat.

    Regards
    John

     
    • John Matthews

      John Matthews - 2008-01-28

      Problem solved (thanks Anil)- looks like it's a Windows/Linux CR/LF issue. I downloaded the CUnit-2.1-0-src.tar.gz file instead of the zip, and that worked fine.

       
    • John Matthews

      John Matthews - 2008-01-24

      I also tried the alternative 'standard GNU build system' (from the README) on a clean unzip:

      [johnm@wey CUnit-2.1-0]$ aclocal
      /usr/share/aclocal/ao.m4:9: warning: underquoted definition of XIPH_PATH_AO
      run info '(automake)Extending aclocal'
      or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
      [johnm@wey CUnit-2.1-0]$ autoconf
      [johnm@wey CUnit-2.1-0]$ automake
      configure.in:162: required file ./config.guess' not found configure.in:162: required file./config.sub' not found
      configure.in:162: required file ./ltmain.sh' not found [johnm@wey CUnit-2.1-0]$ configure checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes : command not found/downloads/CUnit-2.1-0/missing: line 5: : command not found/downloads/CUnit-2.1-0/missing: line 10: : command not found/downloads/CUnit-2.1-0/missing: line 15: : command not found/downloads/CUnit-2.1-0/missing: line 20: /home/johnm/Desktop/downloads/CUnit-2.1-0/missing: line 34: syntax error near un'xpected tokenin
      'home/johnm/Desktop/downloads/CUnit-2.1-0/missing: line 34: case "$1" in configure: WARNING:missing' script is too old or missing
      checking for gawk... gawk
      checking whether make sets $(MAKE)... yes
      ---------- Disabling debug mode compilation.
      ++++++++++ Enabling automated(XML) mode compilation
      ++++++++++ Enabling basic mode compilation
      ++++++++++ Enabling console mode compilation
      ---------- Disabling curses mode compilation
      ---------- Disabling examples mode compilation
      ---------- Disabling test mode compilation
      ---------- Disabling memtrace functionality at compile time
      ---------- Disabling use of deprecated v1.1 names
      checking for gcc... gcc
      checking for C compiler default output file name... a.out
      checking whether the C compiler works... yes
      checking whether we are cross compiling... no
      checking for suffix of executables...
      checking for suffix of object files... o
      checking whether we are using the GNU C compiler... yes
      checking whether gcc accepts -g... yes
      checking for gcc option to accept ANSI C... none needed
      checking for style of include used by make... GNU
      checking dependency style of gcc... none
      checking for a BSD-compatible install... /usr/bin/install -c
      checking whether make sets $(MAKE)... (cached) yes
      configure: error: cannot run /bin/sh ./config.sub

      Any suggestions anyone?

       

Log in to post a comment.