Compiling the tutorial on Mac OS X

Help
Anonymous
2004-06-12
2004-06-13
  • Anonymous - 2004-06-12

    Hi!

    I am newbie to CS and I am starting to develop an application. I am using v.97 of Crystal Space and currently stuck at Chapter 5.2. I have tried to compile the application according to Chapter 5.8.15 but I was never successful.

    First of all I have tried to compile it with bash and the "make" command and the appropriate makefile. I experimented a lot but did not get any proper results.

    It is important for me that I get this thing compiled on Xcode. So far I have been successful compiling it on Xcode - at least it does not report any errors on compiletime. However, when I launch it Xcode displays this error:

    "ZeroLink: unknown symbol '__ZN4iSCF3SCFE'

    Simple has exited due to signal 6 (SIGABRT)."

    I have experimented with the compiler flags, e.g.

    -I/Users/developer/Library/CrystalSpace_v97/include -force_cpusubtype_ALL -fno-common
    (from the cs-config)

    I tried to use Makefiles (BTW the documentation that came with Xcode 1.2 is outdated - the ADC Website has a updated version) and it does compile the project but again it only displays this error message. Currently the compiler shows this error message:

    "Exception starting task (/Users/developer/Simple/Makefile) ; name NSInvalidArgumentException, reason: launch path not accessible"

    You see - there are many problems and I do not think I can solve them without your help.
    Any solutions? Thanks in advance.

     
    • Eric Sunshine

      Eric Sunshine - 2004-06-13

      I upgraded the HOWTO so that it gives additional instructions for MacOS/X. I also fixed several problems with cs-config and Makefile.template which prevented applications from building correctly on MacOS/X. (I don't have MacOS/X, so these changes were made blindly, but they should improve the situation anyhow.)

      I also updated the HOWTO so that it talks about the Jamtemplate utility (CS/scripts/jamtemplate/README), which creates a much more functional external project skeleton than the Makefile-based one described by the HOWTO. You may have much better luck with Jamtemplate.

      These changes and fixes should appear in the CVS repository within five hours or so. The updated documentation should appear online within twelve hours.

       

Log in to post a comment.