On Wed, Jan 2, 2013 at 10:21 PM, Oskar Kvist <tufflax@gmail.com> wrote:
> On Wed, Jan 2, 2013 at 7:44 PM, Oskar Kvist <tufflax@gmail.com> wrote:
> >
> > Hi!
> > I am having a great deal of trouble finding the correct version of
> > Ruby to use with Vim without Cream version 7-3-744.
> >
> >  :help ruby-dynamic says:
> >
> > >You need to install the right version of Ruby for this to work.
> > >You can find the package to download from:
> > >http://www.garbagecollect.jp/ruby/mswin32/en/download/release.html
> > >Currently that is ruby-1.9.1-p429-i386-mswin32.zip Currently the
> > >name is "msvcrt-ruby191.dll".
> >
> > But when I look in gvim.exe, it says msvcrt-ruby19.dll (notice
> > 19.dll, not 191.dll). But I can't find a ruby version with that
> > dll! Even version 1.9.0 has a dll named msvcrt-ruby190.dll. What
> > should I do?
>
> I made this thread on SO that explains more what I've done.
> http://stackoverflow.com/questions/14131750/cant-find-the-correct-version-of-ruby-for-vim-without-cream
>
> But I took a look at the release notes, and it says:
>
[...]
>
> Notice -DDYNAMIC_RUBY_DLL="msvcrt-ruby19.dll". I'm not sure if that
> is the problem, but I think that might be wrong, because there is no
> such file in ruby 1.9.1.


Cream's Vim build was compiled with Ruby 1.9.3 from
http://rubyinstaller.org/. For some reason, that distribution
maintains the 1.9.1 file structure under bin/, include/, and lib/. I'm
not much for tampering with defaults of dependency distributions or
Vim's build process so this worked pretty much out of the box. It has
been quite a while since the Vim build worked with Ruby, so perhaps
the recent fixes didn't quite pick up the error your seeing? I might
start by installing with that distro and putting on path.

If that fails to help, I recommend taking your issue to the vim
mailing lists (probably vim-dev) since they are the authors and
maintainers of Vim and might understand how to help.

--
Steve Hall  [ digitect dancingpaper com ]
:: Cream for Vim (http://cream.sourceforge.net)