On 8/14/06, Steve Hall <digitect@dancingpaper.com> wrote:
On Mon, 2006-08-14 at 15:22 -0700, Shaun Walbridge wrote:
> Hey Guys,
> Long time user, first time poster.

Glad to hear from you!

> I'm currently using cream on windows, and I've tried to no avail to
> get filetype associations working.
> I followed the directions listed in cream/docs/WINDOWS.txt: I've
> created creamopen.vbs, and imported the registry entry for
> associating cream with the .txt extension. I've changed the paths as
> necessary to reflect cream's current use of vim 7. If I run the
> command directly, i.e:
>   c:\progra~1\vim\vim70\cream\creamopen.vbs c:\open_me.txt
> It works just fine. But trying to associate creamopen.vbs with any
> given file always results in `<filename> is not a valid Win32
> application.' Any advice?

If you've installed the Context Menu ("Edit with Cream/Vim"), just
take the value from  HKCR\*\Shell\Cream\Command, something like:

  c:\progra~1\vim\vim70\gvim.exe "-U NONE -u \$VIMRUNTIME/cream/creamrc"

although I'm not on Windows right now to check that...probably not
quite right.

I tried this approach and it works just fine.  I'd tried previously by copying the shortcut data, but it wasn't properly escaped.  Thanks for the help!


Otherwise, this sounds like a pathing issue due to spaces, quotes, or
similar. (Does :messages at the command line give you more feedback?)
You might just test various incantations:

  "c:\progra~1\vim\vim70\cream\creamopen.vbs" %1
  "c:\progra~1\vim\vim70\cream\creamopen.vbs" "%1"
  "c:\progra~1\vim\vim70\cream\creamopen.vbs %1"

and so on, but the first suggestion is a much safer bet.

Steve Hall  [ digitect dancingpaper com ]
:: Cream... something good to put in your Vim!
::   http://cream.sourceforge.net