problem compiling on solaris8

Freud
2001-08-03
2001-08-20
  • Freud

    Freud - 2001-08-03

    Hi,

    I am trying to compile CppUnit on Solaris 8 with the Forte 6 (Update 1) compiler.
    I launch the following configure command:
    env CC=cc CCC=CC LD=CC ./configure
    The compilation (excepted a namespace problem, bug 445327) and the linkage work fine but when I run the hierarchy example, I get a core dumped when the TextTestResult prints the line of the failure. I get the same error with the static and the shared libraries of CppUnit.
    Does anyone have the same problem?

    Bruno.

     
    • George Singletary

      I am having the exact same problem; I posted it as a problem but have gotten no response.

       
    • Freud

      Freud - 2001-08-06

      Thanks for your feedback (I was about to become crazy ;-))! I hope someone can help us now...

      Bruno.

       
    • Alberto Mascheroni

      Hi all,
      I experienced a similar problem, hopefully it is the same :-)
      I compile cppunit framework under SunOS 5.6 with Forte 6 upd. 1 compiler. If there no failures are detected, the test program executes correctly. If I introduce a failure (using the assert macro) the program aborts with a core dump.
      The problem is that in C library another assert macro is defined (man -s 3C assert). No warning is given by the pre-compiler because there is an undef before.
      Depending on the order in which files are included, the "right" or the "wrong" version of assert are used. To solve the problem, one could find the proper include order, but I think the best way should be to change the name of the cppunit assert macro.
      To know if you got the same problem, try to rename the assert macro in TestAssert.h with another name and, of course, do the same in your test class. This way, it should execute fine.

      Alberto

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks