coverJuke on 64 Bit Vista?

Help
2008-12-19
2013-04-22
  • Manuel Frischknecht

    Hi there!

    First, I have to admit that coverJuke is a great music player; especially because despite its great style it isn't overloaded with useless functionalities like many others.

    It works great on my notebook, but unfortunately I'd like to use it mostly on my desktop PC, which runs on a 64 bit Vista. There, I just get an empty window of coverJuke (Screenshot: http://web440o.dynamic-kunden.ch/coverJuke.jpg\); I think the OpenGL component doesn't work well. Is there any chance to recompile coverJuke for 64 bit systems? I had a look on the info page of GLUT on opengl.org, but the only 64 bit version listed there is made for solaris...

    Hopefully,

    Mani

     
    • Mikael LE BERRE

      Mikael LE BERRE - 2008-12-19

      Hi Mani,

      I understand your problem...

      But I've no 64Bits computer at home. So I can't compile anything for you.

      You must re-compile the source alone...

      I'm so sorry.

      Mikaël

       
    • Jens Wolf

      Jens Wolf - 2008-12-19

      Hi Mani,

      I've a similar problem like you. I trie to run coverjuke on a desktop (touchpanel) PC too.
      and OpenGL is not supported by my graphical card. Which graphic card does your pc have?
      But I've an solution. I found a tool called "GLDirect 5.02" It's an universal graphic card driver to convert OpenGL to DirectX! And It's freeware! With this tool coverjuke runs with some little reservations. These reservations are that you can not click with your mouse on the covers. but everything else works fine.
      I hope Mike can fix this Bug.

      Greetings.

       
    • Mikael LE BERRE

      Mikael LE BERRE - 2008-12-19

      Hi demmy86)!!! :-)

      For the click on a cover, I use an OpenGL Specific fonction... it's picking.

      Maybe GLDirect can't emulate this fonction in directx...

      So I must try your program on my old computer to see your bug!

       
    • Manuel Frischknecht

      Hi once again.

      Phew, I found a solution without having to do the whole recompiling (Visual Studio doesn't really seem to like the code).

      The Problem was that you need the glut.dll in the folder C:\Windows\SysWOW64 instead of C:\Windows\System32. Didn't think of this...
      So, while setting up GLUT for my Visual Studio, suddenly the whole thing worked without a Problem :D

      Thanks for your advices anyway; i'll have to enjoy some music ^^

      Greetings,

      Mani

       

Log in to post a comment.