1st time connect trouble

  • pabloalto

    pabloalto - 2008-01-03

    I know - it's a question that's been asked, but I have a mac mini I'm trying to access from a macbook over airport. No luck.

    COTV on the macbook sees the mini's bonjour name, but can't connect.

    I use the ip address for the mini, likewise, no go.

    Do I need to install this on the mini first? I'm confused by the password setup on the macbook client, why does a client have power to set it's own password?

    any help appreciated... thanks!

    • pabloalto

      pabloalto - 2008-01-03

      a followup to my newbie question - do I need to turn on the remote desktop on the mini first? I had that on, but it didn't seem to matter...

    • Kurt Werle

      Kurt Werle - 2008-01-03

      There is a pretty good write-up on how to connect at


      The most likely problem is firewall issue[s]:

      Q: OSXvnc is running but I can't connect to it/How do I configure my Firewall to allow OSXvnc?

      A: If you don't see anything in the OSXvnc log then your network isn't allowing the connection. The most likely cause of this is that your MaxOS X machine is running the built-in firewall. You can configure the firewall to allow port 5900 (or whichever port VNC is running on). Using the System Preferences application go to Sharing and then Firewall. On that panel, "Add.." another service for port 5900 and call it VNC

    • pabloalto

      pabloalto - 2008-01-05

      Thanks for the tip - unfortunately it didn't help. I did have another sharing item for MSN that specifies 5900 as well.... but my guess is that once the port is open for one item, it ought to be open for another (VNC) too. Would specifying that port in two sharing items cause a problem?

      The target Mac is shared as "mymac.local" and I've also tried connecting just as "localhost".

      I've also tried with the firewall off entirely, and it STILL won't connect!


      • Kurt Werle

        Kurt Werle - 2008-01-05

        Kurt's HOWTO for secure VNC:

        On the host Mac:
        Enable remote login in sharing preferences (ssh)
        Fire up you VNC server (COTVNC, or whatever)

        On the client:
        Fire up terminal
        Assuming your VNC server is running on port 5900
        ssh -L 5900: your.server

        Right now we start to know things.  Either you can ssh to your server, or you can't.  If you can't ssh to the server, then you have some kind of network problem.  Either there are routing issues, or firewall issues, or your server isn't running sshd correctly.  If you can ssh but it complains about forwarding the port, then that port is probably already in use or blocked or something.

        Fire up Chicken on the client
        connect to localhost on port 5900 (display 0)

        You're in.

        If that doesn't work, then type the following in the terminal window you ssh'd (which is now connected to the remote machine):
        telnet localhost 5900

        It should say something like
        RFB 003.008

        If it does not, then you have had some kind of problem running the server.


Log in to post a comment.