Can't use COTV to VNC into my PC

Help
altoidboy
2006-02-23
2013-04-30
  • altoidboy

    altoidboy - 2006-02-23

    i'm having a lot of trouble vnc'ing into my pc.

    pc is running win xp home, sp2, running realvnc (free version). connected via a belkin router. i want the pc to serve, and the mac to view. (about a year ago someone set up my system to vnc, and it worked, so i know it's possible, however i've since wiped the pc's drive). the pc has my local ip address 192.168.2.5.

    mac (viewer) is running cotv 2.0b4. whenever i try to connect, it won't connect.

    i have tried:

    *disabling my router's firewall (doesn't make any difference)

    *using apple's network utility to port scan: it says "open tcp port: 5900" for the pc's ip

    *with and without authentication (switched it on and off in realvnc)

    *realvnc's server properties are set to accept connections on port 5900 (and to serve java viewer via http on port 5800, if that matters)

    *windows firewall > made sure that vnc is an exception, port 5900, tcp.

    *windows firewall> advanced > network connection settings > local area connection is checked, and in settings, vnc is checked (inside vnc settings, the "name or ip address of the computer hosting this service on your network" is set to 192.168.2.5 - presumably this is right since i want that computer to serve vnc, and the external and internal port numbers are both set to 5900, and tcp is checked)

    can't think of anything else to try. whenever i try to get cotv to connect, it gives me the spinning beach ball for about 30 seconds, then tell sme "could not connect to server 192.168.2.5:11800, operation timed out" (why is it searching for port 11800???)

    in cotv, i have the host set to 192.168.2.5, and display set to 5900 (the default)

    i'm confused as to the difference as to display vs. port. i thought display was supposed to be 0. if i change display to 0 then connect, it opens a window but then says the server closed the connection (immediately).

     
    • Jason Harris

      Jason Harris - 2006-02-24

      Display should be zero, Chicken 2.0b4 now uses host:port syntax if you want to specify a custom port. 

      I _think_ the authentication in RealVNC is using Windows authentication, so you'll want that turned off.  You _do_ still need a password, I hope. 

       
      • Ward Clark

        Ward Clark - 2006-06-16

        Jason wrote ...

        > Display should be zero,

        My earlier XP Connection was configured for Display 5900 -- it timed out just like altoidboy described.  When I changed to Display 0, Connect is instantaneous on my LAN.

        > I _think_ the authentication in RealVNC is using Windows authentication, so you'll want that turned off. You _do_ still need a password, I hope.

        RealVNC 4.1.2 has three Authentication choices:

        *  No Authentication -- doesn't ask for a password (a risky choice, in my opinion)

        *  VNC Password Authentication  -- separate from XP user account password

        *  NT Login Authentication -- disabled on my XP Pro system

         
    • mgsupport

      mgsupport - 2007-03-27

      I had this problem crop up now and again in Mac to Mac logins. I was using 5902 as the VNC port. Sometimes or on some systems, not sure which, it would give me "11802 timed out" ... wtf? So entered just "2" into the COTV "display" field and problem resolved. Don't know what changed - may have been between 2.0b2 and 2.0b4 but all better now.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks