Is anyone looking at the Windows 7 issues??

2009-09-18
2013-06-12
1 2 > >> (Page 1 of 2)
  • Derell Licht

    Derell Licht - 2009-09-18

    Several of us are experiencing the keyboard-lockup problem in Windows 7.  This occurs, apparently, with any shell except cmd.exe (I'm using tcc/le).  Someone had offered a possible solution, but it did not work for me, nor for at least one other person.  I would very much like a fix for this issue, so I can start using Console2 again…

     
  • Josh

    Josh - 2009-09-22

    Yeah, i really miss using this great app. I get the lockup using cygwin shell, but I've been checking this site for updates nearly every day in hope of a fix.

     
  • Kevin C. Dorff

    Kevin C. Dorff - 2009-10-16

    Does anybody know of alternatives to Console? I need something with Console's functionality but most of my systems are now or will soon be Windows 7 and I already miss Console something fierce since Console doesn't support Windows 7 and it doesn't appear it will any time in the near future.

    Note: I need to to be able to work with both CMD and Bash (Cygwin). I like the way Copy/Paste and Tabs work on console.

    I've done quite a bit of Google'ing and don't really find any alternatives.

    Kevin

     
  • Cthulhux

    Cthulhux - 2009-10-16

    PowerCmd might be of interest, but it is not free.

     
  • Marko Bozikovic

    Marko Bozikovic - 2009-10-18

    I plan to look at Win7 issues as soon as I buy a new box and Win7 :-)

    Is Console working for anyone on Win7? And if it is, under which conditions?

    Cheers,
    Marko

     
  • Henrik Antonsson

    The text disappears after a second.
    I use to put the folder under program files but it seems to work better if I put it in C: directly

    /anton

     
  • Kevin C. Dorff

    Kevin C. Dorff - 2009-10-21

    Tuxman - thanks for the PowerCmd recommendation. I tried it and was almost sold on it except I DO mostly use Bash / Cygwin. PowerCmd hijacks the Control-A to "select all" (for copy/paste) - this is kind of a problem for Bash where Control-A means "jump to the start of the current line" (an Emacs key binding).

    With a little work, I got "mrxvt" up and running under Windows 7. This isn't nearly as slick as Console but it DOES work. It's tabbed, works with Windows 7 (although requiring having Cygwin + X running), copy/paste works like Console -  and it's free. This will work fine for me, at least for now. I've started writing up some instructions for getting "mrxvt" running (notably under Windows 7) - I found some other instructions but they were a bit out of date and refer to inappropriate packages and a few other oddities. If anybody here is interested in  running mrxvt while we wait for Console to work with Windows 7 let me know.

    Kevin

     
  • Kevin C. Dorff

    Kevin C. Dorff - 2009-10-22

    OK I think I finally finished my write up of getting mrxvt running under Cygwin / X. It's up to date with the latest Cygwin package revisions + works nicely with Windows 7. See

        http://www.dorffweb.com/wordpress/?p=590

    If you are using Windows 7 and missing Console and don't mind running Cygwin and X-Windows, this seems to works great.

    Kevin

     
  • Michael Kairys

    Michael Kairys - 2009-10-28

    I just put Windows 7 on one of my systems and immediately fell victim to the "keyboard lockup" problem. It as others have reported; when bash is my shell, C2 will fail to respond to the keyboard (except for ctrl-c) after a small number of commands, usually 1-3.

    I love C2 and am not interested in finding a replacement. I hope Marko can find the time and resources to look into this asap. Should we take up a collection for a new machine?

     
  • Marko Bozikovic

    Marko Bozikovic - 2009-10-28

    Money is not a problem, time is :)

    If you can collect a few free days and ship them to me, I'd be grateful :)

    I was also waiting for things to calm down a bit on the CPU market. Good thing I didn't get i7 9 series…

    Cheers,
    Marko

     
  • Jeremy

    Jeremy - 2009-11-18

    I have it kind of working on windows 7.  However, scrollback doesn't appear to be working for one - it garbles the text in the window.  Also I've had unpredictable behavior with settings - they don't seem to save at all - so the window transparency is always there, I can't set the start directory, etc.  I wonder if that has something to do with UAC or something?

     
  • Paul Moore

    Paul Moore - 2009-11-22

    I had a dig around. The lockup seems to occur in the WaitForMultipleObjects call in ConsoleHook\ConsoleHandler.cpp. I can't see quite why the call would hang (m_consoleParams->dwRefreshInterval is not INFINITE, I'd have thought).

    I'm a bit stuck beyond that, though, as I'm not at all sure what the best way is of debugging cross-process stuff like this :-(

    If anybody can give me any pointers, though, I'd be happy to dig around - as other people have said, I really miss having Console available

     
  • Rob Davenport

    Rob Davenport - 2009-12-01

    Just as an FYI, I've had no lockup problems with C2 on Win7 - but I'm just using CMD.EXE, not bash as the shell.

     
  • Michael Kairys

    Michael Kairys - 2009-12-01

    Yes, seems it only happens with bash as the shell.

     
  • Marko Bozikovic

    Marko Bozikovic - 2009-12-01

    Hi all,

    A friend of mine just installed a fresh copy of Win7 Professional 64-bit. Console works fine with both cmd.exe and bash (shell is set to C:\cygwin\cygwin.bat) under default Administrator account.

    I hate it when I can't reproduce other people's problems….

    Marko

     
  • Kevin C. Dorff

    Kevin C. Dorff - 2009-12-01

    Marko and All,

    I also noticed this morning that I am not seeing "the problem" with Windows 7 64-bit and the latest 1.7 of Cygwin (Bash).

    BUT I am still seeing the problem with Windows 7 32-bit and the latest 1.7 of Cygwin (Bash).

     
  • Paul Moore

    Paul Moore - 2009-12-01

    Marko (and others),

    I see the issue with JPSoft Take Command (tcc.exe). There's a free version (tcc/le) available (www.jpsoft.com) and I believe others have seen the issue there. I don't know if that would help you reproduce the issue.

    I'll try a Win7 64-bit VM and see if that works OK.

    I did some digging last night, and it looks as if it might be to do with the way Console forwards messages to the console window (in ConsoleView.cpp) - Win7 has a new process which hosts the console window (conhost.exe) and there seems to be a new security model involved. I'm trying to narrow down the issue a bit, but it's nasty trying to debug multithreaded multiprocess code like this :-(

    If you've got any suggestions on how to dig around in the debugger to see what's going on in a "stuck" console program, I'd be more than grateful.

    Paul.

     
  • Derell Licht

    Derell Licht - 2009-12-03

    I'm seeing it with tcc/le, which is the only shell that I use.  I'm using Win7 32-bit, and I run as user, *not* as admin.  I'm seeing the lockup on two different machines.

     
  • Derell Licht

    Derell Licht - 2009-12-03

    As a further note, I've also confirmed that C2 works fine with cmd.exe.  What a dilemma - C2 or tcc/le ?? 

    I *did* try running C2 as admin, with tcc/le, and it still locked up.

     
  • Marko Bozikovic

    Marko Bozikovic - 2009-12-03

    @gorlash: what happens if you start C2 with cmd.exe and then run tcc/le from cmd.exe?

    Marko

     
  • Paul Moore

    Paul Moore - 2009-12-03

    I've tried that (start C2 with cmd.exe and then run tcc from cmd.exe) and it still locks up.

     
  • Seance

    Seance - 2009-12-03

    Hi,

    I'll add my voice to the requests that Console2 be fixed for Win 7. I too experience the lock-up; I use C2 for cmd.exe and would very much like to use it for Git Bash and TCC/LE, but unfortunately this is not possible because of the lock-up problem. I can confirm it both in running a new shell in a tab and running the shell program from within a Console2-launched cmd.exe.

    I'm using 32-bit Windows 7.

    Console2 is a really great thing, I sincerely hope it can be fixed to support Win 7 as there really is no good replacement for this slick beauty!

     
  • Derell Licht

    Derell Licht - 2009-12-03

    Aye, confirmed here too.  tcc/le locks up when run from cmd.exe.

     
  • Rob Davenport

    Rob Davenport - 2009-12-04

    As another datapoint, I'm not seeing the lockup problem with TCC/LE on Win7/64 (logged in as an admin user).

    (And thanks for the tip on TCC/LE - I'd used 4DOS and 4NT years ago and loved them, even got licenses for our company for a while, but had to give them up for 'standardization'.   Didn't realize TakeCommand was still around - I've missed that SELECT command!)

    Now if only I could get XKeymacs working under Win7/64…

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.