Win7, GnuWin32 and less

2009-12-01
2013-06-12
  • Rob Davenport

    Rob Davenport - 2009-12-01

    Just installed GnuWin32 on this Win7 x64 box, and was trying to get less working (one of my favorites from GnuWin32), but starting it in C2 just flashes (I can see the file briefly), then back to console screen, and after a keypress Windows says it's stopped responding (less, the Console host, and the CMD processor all stop responding).
    Tried with the 32-bit and Mr. Blaschke's 64-bit Console2, same thing.
    But the GnuWin32 less.exe does run as expected in the standard Win7 CMD.exe. 

    I've tried less options of -d, -B, -C, and -X and the only success is with -X (don't use termcap init strings).   But that only shows three lines from the file (what would normally be the last three lines on the screen) but spread out with about 10 lines between them, and many functions don't appear to display correctly.

    I've tried setting TERM (to 'ansi-nt' and then 'cygwin') and TERMCAP (to '//C/sys/gnuwin32/etc/termcap' as suggested in the termcap file).
    No joy. 

    Anyone else using GnuWin32, Win7, and CMD (not bash/cygwin), and if so does less work in Console2 for you?

     
  • Rob Davenport

    Rob Davenport - 2009-12-04

    less works fine under CMD outside Console2.  And under TCC/LE outside Console2.   A temporary workaround I think might be to do "start /wait c:\sys\gnuwin32\bin\less.exe $*" as an doskey macro/TCC alias for it.  It'll pop up in another window, but, eh, that'll do for now.  
    Would really like to know why everything crashes when starting GnuWin32 less under Console2, though.

    Rob

     
  • Michael Carman

    Michael Carman - 2010-05-27

    I have the same setup (Win7 x64, GnuWin32 version of less in a cmd shell) and see the same behavior under 2.00 build 146. :(

     
  • Derell Licht

    Derell Licht - 2010-06-04

    Unfortunately, as you can tell, activity on C2 development is not very proactive these days, especially regarding Win7/x64.

    One alternative that you could consider is to use the Cygwin package, which contains Win32 ports of all (well, most) of the common *nix tools.  I just checked 'less' on my system (Win7/x64, TCC/LE 11.00.40, Console2 V1.46) and it works fine…

     
  • Anonymous - 2010-06-07

    Bummer to hear "activity on C2 development is not very proactive these days"…  Console2 has worked great for me for a long time now.  I can't imagine Windows command line usage w/o it…

    I'm having the same problem w/ Console2 (2.00.146) and gnuwin32 "less" command.  I'm on Win 7 x64.

    I just noticed it this week.  It might be that I haven't tried this combination since last October.  But I'm pretty sure it worked before that time, on Win 7 x64.

    Maybe I was using a previous version of gnuwin32 or Console2 back then?

    Probably has to do with how less does its fancy ANSI colorized footer/header thing.  Maybe the previous less for Windows didn't do that.  Or, maybe before Console2 didn't report being able to handle color ctrlr codes like that?  I'm guessing here.

    I'd love it if this were fixed (obviously).  Kind of hard to remember not to use "less" or it will crash your console…

     
  • Tao Yue

    Tao Yue - 2010-07-21

    Nope, the colors are not the problem.  If you want to know, please see my comment in bug 2944920.  https://sourceforge.net/tracker/?func=detail&aid=2944920&group_id=43764&atid=437332

    The problem with "less" is tracked by bug 2954008, but the older bug contains more technical information.  Plus, it's much easier just to workaround the "less" problem by running the Cygwin version.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks