Black font on black background?

agressiv
2006-10-16
2013-06-12
1 2 > >> (Page 1 of 2)
  • agressiv

    agressiv - 2006-10-16

    I just downloaded Console and it appears that I have a black font on a black background (I can see a white cursor, and when I "show console" I can see the real command window)

    Whenever I change the font color to anything else, it doesn't save it.  I've even edited the XML file and changed the value to 255, but it overwrites it with a zero (0) when I launch it again.

    Not sure whats going on, (running xp64, not sure if that makes a difference) and I've tried a lot of experimenting - nothing seems to work...

    Any ideas?

    agressiv

     
    • Marko Bozikovic

      Marko Bozikovic - 2006-10-16

      Nope, I don't have a 64bit system to test it...

      Can anyone test this? Maybe build Console for 64 bits?

       
      • calavera

        calavera - 2007-01-22

        I am seeing basically the same issue, thought it appears that my xml configuration file saves my changes just fine. 

        No matter what color I change the fonts to, the text in the console does not display, only the cursor.  I've tried changing the background color as well, no luck.  As one of the previous users said, if I log onto my machine with remote desktop and open Console, I can see the text just fine.  I would like to help with the 64 bit test build... if you could give me a little instruction on where to start or maybe you have a build readme somewhere?  I have visual studio 7.1 and 8.0.

         
        • Marko Bozikovic

          Marko Bozikovic - 2007-01-24

          It would be great if you could debug Console on 64-bit Windows. Building console under 8.0 should not be difficult, jachymko has a nice description (pretty much same holds for 7.1)

          http://jachymko.afraid.org/HowToBuildConsole.htm

           
          • calavera

            calavera - 2007-01-24

            I actually found this guide soon after posting this message... I've got it to build but I'm having some issues with my visual studio setup.  I have stlport in my includes for other applications, and after I build console it wants the stlport dll.  Not a dealbreaker, i just need to do a little investigation.  Hopefully I can work on it some this weekend.

             
    • agressiv

      agressiv - 2006-10-16

      strange.  I came home from work and Console works fine over Remote Desktop.

      I'll reboot and try again from the Windows Console tomorrow.

      agressiv

       
    • JameZ

      JameZ - 2006-10-25

      I'm getting exactly the same thing on XP 64. How annoying!

       
    • Kevin

      Kevin - 2007-02-23

      I'm having this same problems, and I'm also on XP-64.  I haven't tried to remote desktop into my machine, but I know that remote desktop defaults to 16-bit color depth instead of the standard 32-bit.  If I set my display to 16-bit color, then I can see the text in Console without any problem.  This is probably the reason why Console works under remote desktop but not when you're sitting at the machine.  I'm not sure if this will help solve the problem, but it's at least a possible work-around.

      By the way, I'm running Console 2 beta129.  If I run Console 1.5, I don't have any problems in both 16-bit and 32-bit color settings.

       
      • Kevin

        Kevin - 2007-03-02

            I just looked through the bug reports, and I think that this is the same problem that is reported in bug 1639256 (http://sourceforge.net/tracker/index.php?func=detail&aid=1639256&group_id=43764&atid=437332).  If I use Console 2b 125, then the problem doesn't occur.
            The release notes for Console 2b 126 mention that ClearType support has been added for 32-bit color depths.  If I disable ClearType on my XP64 machine, then Console 2b 129 works fine, so it appears that ClearType is somehow causing this problem.
            Do other people who are experiencing this problem have ClearType turned on with 32-bit color depths?  Does switching to 16-bit color or turning off ClearType fix the problem?

         
        • Marko Bozikovic

          Marko Bozikovic - 2007-03-04

          Hm. I'll have to test this. Can you recreate the problem on another machine?

           
          • Kevin

            Kevin - 2007-03-05

            Unfortunately, I only have access to one XP-64 machine.  I've installed Console2 b129 on my machine at home which runs 32-bit XP and haven't had any problems there regardless of the color depth or ClearType settings.

             
    • Derek D Owens

      Derek D Owens - 2007-03-15

      Just for further confirmation, I am running build 129 on WinXPSP2 (32bit) and experience the "black on black" symptom as well.  Actually I am using tab backgrounds with wallpaper opacity and the font disappears when ClearType is enabled.  Changing back to standard font smoothing fixes the issue.

       
    • Marko Bozikovic

      Marko Bozikovic - 2007-03-16

      I cannot reproduce the problem with ClearType. Can someone who experiences BoB :) problem with ClearType enabled send me their console.xml and display settings data (screen size, color, etc)

       
      • Kevin

        Kevin - 2007-03-19

             I just downloaded 2beta130, and I get the problem with the included console.xml.  Do you still want me to send it to you?  (I'm not sure if it gets modified on the first run or anything like that.)
             As far as desktop settings, I have two monitors, both of which are set at 1280x1024 and 32-bit color.  ClearType is enabled and I've downloaded and run Microsoft's ClearType Tuner PowerToy (http://www.microsoft.com/typography/ClearTypePowerToy.mspx).  I'm also running UltraMon 2.7.1 (http://www.realtimesoft.com/ultramon/), which adds some niceties to the second monitor, but exiting that doesn't affect the problem.  The video card is an Nvidia Quadro NVS 285 and I'm using the Nvidia driver version 77.56.  I have Multiview (Nvidia's multiple monitor tools) disabled.  Do you want any other settings?
             My home machine runs XP SP2 (32-bit) with similar settings and doesn't have the problem.  The only differences are the monitor resolution and video card.  That has an Nvidia 6600 and uses the Nvidia 8x.xx drivers.  I can't remember what resolution I have those monitors set at.  I think it may be 1152x864, but I'll double check when I get home.

             Also, I just discovered that if I disable the second monitor on my work machine and then restart Console, the text appears, even if ClearType is enabled.  Derek, are you running multiple monitors?

             I also didn't realize how out of date my video card drivers on my work machine are.  I'll try updating to the 9x.xx series of Nvidia drivers and see if that fixes the problem.

         
      • Kevin

        Kevin - 2007-03-19

        I just got home and checked my settings on my home machine (the XP SP2 32-bit machine that doesn't have the black-on-black problem).  It's running an Nvidia 6600 GT with Nvidia driver version 84.21.  It also has two monitors, both of which are at 1280x960 and 32-bit color.  I tried setting the resolution to 1280x1024 (which is the only display setting I know of that's different between the two machines) and running Console, but that didn't make the black-on-black problem occur.

        Also, before I left work I upgraded the Nvidia drivers on that machine from 77.56 to the newest non-beta version: 93.71.  That didn't affect the black-on-black problem.

        I also played around with the background settings within Console (transparent background, wallpaper background, etc) on my work machine.  None of those had any affect on the problem.

         
      • sanjiyan

        sanjiyan - 2007-08-27

        I also have the same BoB behavior when I use two monitors on beta 131 (e.g. I can only see the text when I am only using a single monitor or when I switch to 16-bit color depth). I'm running on a Radeon X600, so this is not a hardware incompatibility issue specifically with Nvidia cards.

        My display environment is:
        Two monitors:
        1 - 1920x1200
        2 - 1600x1200
        both running at 32-bit color depth.

        Running on WindowsXP 64-bit Edition SP2. Console 1.5 works (albeit I'm having issues with it refreshing, it seems to only work a few seconds before I have to force a refresh by reloading the config file; I've been using my own custom XML file for it).

        Dxdiag reports a driver version as 6.14.0010.6606 and 256MB memory on the card.

        Where should I send a copy of my console.xml?

         
        • Vladimir Sizikov

          Hi,

          I have the same problem with my Vista x64 Ultimate - I see black screen, and no text (and changing any colors in properties does not work). I do have 2 monitors.

          I tried with the latest beta 132 and nothing has changed. :(

          The last working version (meaning that I can see text in console) is 2.0 beta 125, but it doesn't work well on Vista x64, some programs just fail to start when executed from the Console (including some java, and cygwin), that's the error I often get:

            46884 [main] bash 2340 fork: child -1 - died waiting for longjmp before initialization, retry 10, exit code 0x1000000, errno 11
          bash: fork: Resource temporarily unavailable

          So, with regret, I'm back to CMD.exe for now, hoping that future versions of Console will work, since I really like the multi-tab console experience. (If I only knew earlier that Console2 won't work on Vista x64, I'd probably wait and would stay with Win XP a bit longer).

          Thanks,
            --Vladimir

           
          • Marko Bozikovic

            Marko Bozikovic - 2007-10-21

            Vladimir, problems with fork might not be caused by Console. Try using cmd.exe to start your bash shell in Console adn see what happens.

            Which cygwin programs are causing you trouble?

             
        • Marko Bozikovic

          Marko Bozikovic - 2007-10-21

          You can send it directly to me, but I don't think the cause of the problem are 'problematic' settings... Several people with repainting problems have already sent me their settings and I couldn't reproduce the problem...

           
          • Jason Copenhaver

            I lookd at this some on my XP 64 systems as I have the same problem.  I think it all boils down to the fact that the normal windows GDI routines (DrawText etc.. http://blogs.msdn.com/andreww/archive/2007/10/10/preserving-the-alpha-channel-when-converting-images.aspx\) don't respect alpha channels so when you do the AlphaBlend command there is no telling what is in the alpha channel.  If you do some searching on GDI and alpha channel you'll see other people have this problem.  So because Console is using essentially uninitialized memory it will work on some systems and not others.  I couldn't find an "easy" way of fixing this.  If you change the blendfunction parms (AlphaFormt = 0, SourceConstantAlpha = 254) you'll see that the ClearType text shows up just fine on an XP 64 system but I'm not sure what this will do for the other transparency settings.  Just thought I'd let you know as I'd really like to turn cleartype on but I'd also really like to keep using Console2.

             
            • Marko Bozikovic

              Marko Bozikovic - 2008-01-08

              Nice catch :)

              I'll try to see what I can do, but I don't have access to 64-bit system, so I can't test it. Also, I'm affraid that any per-pixel manipulation will severly degrade performance...

               
              • Donovan Lange

                Donovan Lange - 2008-03-06

                I'm pretty sure I can confirm Jason's suspicions.  After rebuilding b138 and forcing m_bUseTextAlphaBlend = false in ConsoleView.cpp, text now shows up correctly on my X64 Server 2008 machine.

                Donovan

                 
                • Christopher

                  Christopher - 2008-12-13

                  I am still having this problem. I cannot see the text even when changing fonts/colors.

                  Vista 64, 2 monitors.

                   
    • Marko Bozikovic

      Marko Bozikovic - 2007-03-21

      Kevin, I'll try to replicate the problem at work, where I have two monitors...

       
    • Kevin

      Kevin - 2007-05-15

           I just tried out Console 2b 131 on my work machine.  The BoB problem still occurs, even if I go into the settings and change font smoothing to none and then restart Console.  As with before, disabling the second monitor, disabling ClearType, or setting the monitor to 16-bit color will fix the problem.
           Also, I tried building Console 2b 131 using Visual Studio 2005 and jachymko's instructions.  I can build the 32-bit version without any problems (I didn't even need to use the Console.rc trick).  I built both the Release and Debug versions, but I experience the BoB problem with both.  I tried changing the platform to x64, but couldn't successfully build Console.  I get 11 linker errors, all "LNK2019: unresolved external symbol" that appear to be coming from Boost.  To get Boost, I just downloaded boost_1_33_1.exe from http://sourceforge.net/project/showfiles.php?group_id=7586&package_id=8041.  I tried setting Visual C++ to not use precompiled header, but I haven't separately built any part of Boost, so I'm not sure if I need to do that.

       
1 2 > >> (Page 1 of 2)

Log in to post a comment.