Ctrl-c doesn't work?

  • Kyle McKnight

    Kyle McKnight - 2012-10-03

    Does Ctrl-c not work to stop a running command in the console? It seems that it doesn't kill commands for me. I'm actually using consle2 to run a PowerShell session and if I use a cmdlet that requires a parameter without filling in the parameter, it will prompt me for the parameters. Stanard PowerShell, but if I want to press ctrl-c to braek out of the command, it doesn't let me


  • mil_spec

    mil_spec - 2012-10-03

    I second this question.

    Ctrl-c worked for me for a long time.

    I'm not sure if it  stopped working when I switched computers (and re-installed a later version) or if I accidentally tweaked a setting.

    Console nicely plugs a hole in windows. Yet I'd like ctr-c back. On more than one occasion i've kicked off a build then remembered I forgot something and want to cancel it. Without ctrl-c I need to go to the task manager, kill the process, etc..


  • Vivian De Smedt

    Vivian De Smedt - 2012-10-03

    Are you sure that Ctrl+C is not mapped to Copy selection in    .
    In my version if I clear that mapping the Ctrl+C touch is working like normal.

  • Kyle McKnight

    Kyle McKnight - 2012-10-03

    d'oh! Good call. That worked haha.

  • Vivian De Smedt

    Vivian De Smedt - 2012-10-08

    I have build a new version of Console-devel 2.0b148b available at:

    Where you can test a new way to bind the interrupt command to e.g.: Ctrl+I and get a way to have access to the the interrupt command and keep your binding with Ctrl+C for the Copy selection command.


  • Kyle McKnight

    Kyle McKnight - 2012-10-08

    Awesome! Thanks!


Log in to post a comment.