Console encoding problem

  • MaeSiuS

    MaeSiuS - 2011-06-24

    I ask for your help regarding Console encoding.
    I use an application (AutoHotkey, WindowsXP) for automatically replacing text that i type. This works in every application I tried so far (CMD included), but not in console.
    if i type "mpe.." in CMD it gets geplaced by AutoHotkey with

    C:\Documents and Settings\mapo8046\mpESO

    if i type "mpe.." in Console it gets geplaced by AutoHotkey with

    c.ßdocuments and settingsßmapo8046ßmpeso

    I already tried using other fonts for Console (right now: Lucida Console) as well as some Windows codepages (850, 1251, 1252, 56001(UTF-8)) all without success. Backslash and colon don't make their way into Console.
    Do you have any suggestions, what i could try to get it working.
    If you tell me that this is a problem with AutoHotkey, I ask you,why Console is the only application that does not give the correct result?

    Regards MaeSiuS

  • MaeSiuS

    MaeSiuS - 2011-08-31

    Hi akirill,
    thanks for your answer. The problems were gone, when I switched back to "normal" autohotkey (not the unicode version).



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks