Run exe on startup

  • Martin Bennett

    Martin Bennett - 2008-11-05

    I've been searching through the forums and the solutions that I've found do not seem to work in my situation.

    I'm trying to run a file through a shortcut I've created. The shortcut looks as such.

    "C:\Documents and Settings\fluxx\Desktop\uo\console.exe" "/c RunUO.exe"

    I've tried:

    /k runuo.exe
    /r runuo.exe
    -c runuo.exe
    -r runuo.exe
    -k runuo.exe

    It's not clear to me in the documentation on how this supposed to work. So if someone could clarify to me how this shortcut should be run, I would really appreciate it.

    • Martin Bennett

      Martin Bennett - 2008-11-06

      Ok, so I tried editing the .xml so that it reads as such:

          <console change_refresh="10" refresh="50" rows="40" columns="120" buffer_rows="200" buffer_columns="0" shell="C:\Documents and Settings\fluxx\Desktop\uo\runuo.exe" init_dir="">

      But now when I run console, nothing shows up. TaskMan shows both Console and RunUO.exe running, but nothing is displaying...there a workaround for this?

    • Martin Bennett

      Martin Bennett - 2008-11-06

      And so apparently that didn't work.

      I've moved that down within the <tabs> and at least console opens up now, but it acts like normal cmd's not wrapping runuo.exe....

      which btw, if i run console, and type in runuo.exe it runs fine!

      wth am i missing here?

    • Marko Bozikovic

      Marko Bozikovic - 2008-11-09

      The command-line parameter is -r (it's in the help ;-)

      And when you write
      "C:\Documents and Settings\fluxx\Desktop\uo\console.exe" "/c RunUO.exe"

      you're sending "/c runuo.exe" as a single command-line parameter (it's enclosed in quotes)

      You should try this:

      "C:\Documents and Settings\fluxx\Desktop\uo\console.exe" -r RunUO.exe


    • Cthulhux

      Cthulhux - 2009-06-13


      "C:\Program Files\Console2\Console.exe" -d C:\users\admin -r far

      This should actually run Console2 in my home directory with the FAR manager open? (The FAR directory is in my %PATH%.)

      Well, it doesn't run FAR. It doesn't run anything. Seems like it ignores the -r parameter completely.
      Any clue?

    • George Aristy

      George Aristy - 2009-06-14

      I am having this same issue with build 144.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks