Failed to open Console2 Tab!

  • PhilippR

    PhilippR - 2009-04-11

    Hi there.

    When I try to start Console2 I always get this error:

    Failed to open Console2 Tab!
    The process could still be running (use the Task Manager to find it and end it).

    (Windows XP SP3)

    What process are you talking about? There is no cmd.exe process running and nothing else that might be related to console2.

    Console2 starts a process console.exe and starts a process cmd.exe before this error happens. when i then click "ok" the console.exe process is gone, cmd.exe is still there.. i can kill this one manually but it doesn't help.

    any ideas?

    cheers guys, happy easter!


    • PhilippR

      PhilippR - 2009-04-11

      i've got the solution:

      I'm using sunbelt firewall, if i disable it, everything works fine

      (sorry for reposting)...


      • Douglas Fontes (dorô)

        I have same problem, but this solution doesn't work with me.
        Can you help me?

  • Jakob

    Jakob - 2009-10-27

    I also have the same problem, and this solution doesn't work with me as well.
    Help, Please!

  • Adam Dymitruk

    Adam Dymitruk - 2009-11-27

    Is this still unresolved? I'm getting this as well. It worked initially then started to fail.

  • electrohead

    electrohead - 2009-12-01

    I'm having the same problem as well… :(

  • roywblack

    roywblack - 2009-12-08

    This most likely means your preferences file(console.xml) has problems. It is located in  the console program folder or C:\Documents and Settings\USER\Application Data\Console if "save setting to user directory" is checked.

  • xephryx

    xephryx - 2009-12-13

    I'm also using sunbelt and can only use console2 when i disable sunbelt. Has anyone discovered a way to use both at the same time without having to disable sunbelt?

  • Marko Bozikovic

    Marko Bozikovic - 2009-12-13

    The problem with firewall/antimalware programs and Console is that Console 'injects' its own DLL into the shell process in order to access its console window. DLL injection is one of the techniques used to inflitrate a system and is commonly prevented by antimalware software.

    It is usually possible to add Console as an exception somewhere in the software's settings…


  • Ramon Crespo

    Ramon Crespo - 2010-02-25

    Following roywblack advice, I took a look at console.xml file. In there there is a line that tells where the cygwin.bat file is expected to be, after changing it to where I have cygwin installed (c: instead of d:) the problem went away.

    Original line:

    <console shell="d:\Cygwin\Cygwin.bat" init_dir=""/>

    My change:

    <console shell="c:\Cygwin\Cygwin.bat" init_dir=""/>
  • Derell Licht

    Derell Licht - 2010-03-06

    After months of using C2 with no problems (Windows 7 32-bit), this problem suddenly started occurring with me as well!!  I tried deleting and re-installing the program, it would work fine until I told it to use my shell (tcc/le), then this problem would pop up.  It turns out, the cause was that I had set the separate TCC/LE shortcut to "Run as Administrator"… and this apparently marks the executable itself as "Run as Administrator"… and that would cause Console2 to fail, unless it also was set as "Run as Administrator" (which I don't want to do).

    So, this is another condition that can cause the "Failed to open Console2 Tab!" problem - if C2 is running as normal user, and your command program is set as "Run as Administrator".  This probably won't occur on WinXP, but it happens on Win7, and probably Vista as well.

  • Anonymous - 2010-05-02

    For those people using Sunbelt.
    I went into the config screen Intrusions, clicked on the Advanced button in Application Behaviour blocking, selected the applications tab, then ticked Starting, Modifying and Launching for console.exe
    After this it didn't work.
    So I disabled the firewall, and it did work. I reenabled the firewall, selected Log and Alert for Console, and it popped up the notification telling me that it was launching another program and it worked fine.  Then I turned off Log and Alert and it still works.
    Who knows why or if it will still work after a reboot…

  • bipll

    bipll - 2010-09-13

    Hello. I've been constantly getting this error message starting this morning. God knows why, but when I changed "C:\Documents and Settings\and_so_on" to "C:\DOCUME~1\and_so_on" in "shell" field of <console> in <settings> part of console.xml, it started to work… seemingly (I've got cygwin installed in "Documents and Settings").
    I think this issue could be cygwin-related, though. I have troubles, of unrecognized nature, starting cygwin's X server.


Log in to post a comment.