#272 hotkey issue in the Settings dialog

closed-fixed
Kirill
None
6
2010-08-26
2008-11-09
bughunter2
No

Command EDIT control has ALT+C hotkey but the Clear PUSHBUTTON control has it too.
I don't even see the need for the hotkey on the Command input field since it's a read-only field.

Discussion

  • Marko Bozikovic

    Marko Bozikovic - 2010-02-10
    • priority: 5 --> 6
     
  • Kirill

    Kirill - 2010-02-12
    • assigned_to: nobody --> akirill
     
  • Kirill

    Kirill - 2010-02-12

    An unofficial build 146.1 for testing purposes is available on my site: http://kirill.ca

    Bug Hunter, could you please try it?

     
  • bughunter2

    bughunter2 - 2010-02-12

    @akirill: It doesn't show a window when I try to run the executable.
    When I run it in a debugger, I see some odd CreateProcess() call with empty strings for its lpApplicationName and lpCommandLine parameters. And later on, it seems to crash while trying to parse %APPDATA%\Roaming\Console\console.xml (which doesn't exist).

     
  • Kirill

    Kirill - 2010-02-12

    I'm sorry. I neglected to mention that you have to get console.xml from the official build. Or better yet, copy your own console.xml into the same folder you extracted my version to.

     
  • bughunter2

    bughunter2 - 2010-02-13

    I guess I should apologize as well, I could just have downloaded the console.xml from the official build.

    Anyway, I'm happy to report the issue is fixed in the 146.1 test build from kirill.ca.

     
  • Kirill

    Kirill - 2010-02-13

    Thank you, Bug Hunter!

    And no apologies were necessary. Consider it "our" fault :)

     
  • Kirill

    Kirill - 2010-02-13
    • status: open --> pending
     
  • SourceForge Robot

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending --> closed
     
  • Kirill

    Kirill - 2010-02-27
    • status: closed --> open-fixed
     
  • Marko Bozikovic

    Marko Bozikovic - 2010-08-26
    • status: open-fixed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks