can't install comport

Help
2012-02-28
2013-04-30
  • Kevin Quach

    Kevin Quach - 2012-02-28

    Hi everyone,

    I'm new to Delphi and to put simply; I need to use ComPort for one of my project and I know it'll work. However when I try to install ComPort to my version of Delphi 2010 enterprise edition; it doesn't work out as instructed on the installation guide.

    Can someone please explain in detail as to how I can install the library?

    Thank you

     
  • Kevin Quach

    Kevin Quach - 2012-02-28

    I should also point out that I was instructed to open the CPortLib2010.dpk and run the file…I did this by pressing F9..then an error message pops up and says:

    "Cannot run project unless a host application is defined. Use the Run|Parameters… dialog box.."

    What do I do now?

     
  • Kevin Quach

    Kevin Quach - 2012-02-28

    Just a quick update…

    In C:/Users/Public/Public Document/RAD Studio/7.0/Bpl…there is 2 documents called "CPortLibD2010.bpl" & "DsgnCPortD2010.bpl" and this was added when I compiled both files as instructed in the read me file.

    Does that mean I've successfully installed the library? If so; how do I now use it?

     
  • Stephen Gaunt

    Stephen Gaunt - 2012-02-28

    The info is not at all clear for XE! I did this yesterday so I know!!
    What you should do after opening the package files is open the project manger, then right click on the 'project' at the top of the tree, in the right click menu you will see the compile and install options, only the Design time package will have 'install' as it is this that creates the component pallet entry.
    Also although will get a message about the componets being added to the pallet, you wont see them right away.
    You must close the project and save changes first.
    Finally you dont have to move the files as it says, edit the search path to include the location of the DCU's.

    If you get windows (W7) messages about not being able to create files you may have to right click the Delphi program folders (as in the message) and change permissions.

     
  • Kevin Quach

    Kevin Quach - 2012-03-07

    THANK YOU SO MUCH! It worked. I thought I'd never be able to install it. Sorry for the late reply though.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks