Experience With XE2 so far

2011-10-01
2013-04-30
  • Paul Vandermyde

    Paul Vandermyde - 2011-10-01

    This is a thread start from a thread called CportTypes in comport library

    1. it would have been better to start a new thread.

    here it is

    2. the components "not working" - you better give some better details than "not working". Describe exactly what you did and what you tried.

    after installing 4.11(what I thought was the newest and worked with D2010) I used the XE version Installed the package and compiled my program.  The screen turned white and the computer locked up computer finally recovered and to be honest I don't remember what it said.

    3. Mac???? Ha! Don't even ask. These things wrap the Win32 API CreateFile apis. If you want to rewrite them for Mac, then please do. But first tell me how you plan to get a working serial port in a mac os x box? The last drivers I know for a USB-to-serial converter that worked on Mac OS at all stopped working on Mac OS X 10.2, about 5 years ago. I don't believe I have ever seen native Intel-mac drivers for OSX leopard, snow leopard, or lion, for a usb serial port convertor.

    Gosh, you know, I am not a computer expert as yourself. So me writing the driver would be out of the question. I was only wondering.  I have only seen the FTDI software for creating a virtual comport on the FTDI website.  I just figured there would be something out there somewhere that would give it a reason for its existence.  I did not realize that it had not worked in 5 years.

    I have gone on to install the 4.10 version of the component. 
    This turned out to be quite a chore.

    I tried to compile the Cport lib14, this did not work as this produced an error regarding Cportlib12,  I tried to add this to the project but could not, so I compiled Cportlib12 then compiled Cportlib14 which ran this time.   I then compiled  DsgnCport14 and installed the component.  I loaded the Comexample which to my delight ran perfectly.  I have not tried the comport multiple thread yet but I soon will.

    I have not tried this in Firemonkey yet as I haven't thought of a good reason to use it.  Other than because it is there.

    Paul

     
  • Brian Gochnauer

    Brian Gochnauer - 2011-10-01

    I'm running version 4.11 on XE and it works fine.  will try XE2 soon

     
  • nicolas

    nicolas - 2011-11-17

    Hello,

    Wath is your tests results on use ComPort librairy on Xe2?

    Thank's for th reply.

    Nicolas.

     
  • Karl Jan Skontorp

    Just tried version 4.11d with Xe2
    Get following error messages when compiling the CPortLibDXE.dpk:

    CPort.pas(1840): E2003 Undeclared identifier: 'i'
    CPort.pas(1841): E2010 Incompatible types: 'AnsiChar' and 'Char'
    CPort.pas(3270): E2066 Missing operator or semicolon
    CPort.pas(1838): E2280 Unterminated conditional directive

    Perhaps I could correct the errors by myself, but I think it's better to correct them in the source, some of it i just typing errors…

    Karl Jan

     
  • Brian Gochnauer

    Brian Gochnauer - 2011-11-18

    Fixed (comport411e.zip)
    I have XE2 but don't plan on testing until next month.
    I don't expect any issues in Delphi  32bit or 64bit apps
    But I don't think it will work in cross-platform (firemonkey, etc)

     
  • edriano

    edriano - 2012-01-28

    Hello.
    I have been using the comport with delphi 7 and now i have migrated to delphi xe2. and i have had some problems with the component. such as datapacket is not working at all. and write string also.
    does some one can help me?

     
  • Karl Jan Skontorp

    Hello edriano!
    I'm using the "e" version with Xe2, and I can confirm that "writestring" is working ok. I'm not sure if I'm using data packet in my application at the moment. I can check my code…
    Karl Jan

     
  • edriano

    edriano - 2012-01-30

    Tthanks for your answer. maybe i have installed it wrong eve though  anything looks write and working. or it is because my windows is a 64 bits.
    if its is not ask to much. do you have a step by step installation guide.
    thank you in advance.

     
  • Karl Jan Skontorp

    I use it on Windows 7 64-bit….
    I think the installation is described in the readme file. I'm sorry, I can't give you a detailed description as I "fight" with installation of this component myself :-). I should have written it down, because I have forgotten how to do it every time I need to install it again :-)
    Be sure to have the 411e.zip version…
    Karl Jan

     
  • edriano

    edriano - 2012-02-01

    Thank you for your replay.
    now it is working right on Delphi xe2 and windows 7 64.
    i had to fight a little bit with the instalation.

     

Log in to post a comment.