C'ero quasi... Errore a ./RUN_Server2.sh

marcopb
2005-03-25
2013-05-02
  • marcopb

    marcopb - 2005-03-25

    Credevo di essere giunto alla fine ed invece... eccomi qua di nuovo... spero sappiate aiutarmi :(((
    Ottengo, dopo un po'.... il seguente errore lanciando il comando RUN_Server2.sh
    ....
    15:00:13,917 INFO  [Trx] commit **** PostMXP134
    15:02:14,473 INFO  [AlertProcessor] processAlert - MAlert[100-Space in Database,Valid=true]
    15:02:15,031 ERROR [AlertProcessor] listSqlSelect - SELECT Tablespace_Name,
    COUNT (*) AS Pieces,
    SUM (bytes)/1024/1024 Free_MB,
    MAX (bytes)/1024 Largest_kB,
    ROUND(MAX (bytes) / SUM (bytes),2) * 100 Ratio,
    SUM (blocks) Free_Blocks,
    MAX (blocks) Largest_Blocks,
    ROUND(SQRT (MAX (blocks) / SUM (blocks)) * (100 / SQRT (SQRT (COUNT (blocks)))),2) Fragmentation_Index FROM DBA_Free_Space GROUP BY Tablespace_Name WHERE GROUP.AD_Client_ID=0 AND GROUP.AD_Org_ID=0
    java.sql.SQLException: ORA-00933: SQL command not properly ended

            at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:125)
            at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:305)
            at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:272)
            at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:623)
            at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:181)
            at oracle.jdbc.driver.T4CPreparedStatement.execute_for_describe(T4CPreparedStatement.java:420)
            at oracle.jdbc.driver.OracleStatement.execute_maybe_describe(OracleStatement.java:896)        at oracle.jdbc.driver.T4CPreparedStatement.execute_maybe_describe(T4CPreparedStatement.java:452)
            at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:986)
            at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:2888)
            at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePreparedStatement.java:2929)
            at org.compiere.util.CPreparedStatement.executeQuery(CPreparedStatement.java:99)
            at org.compiere.server.AlertProcessor.listSqlSelect(AlertProcessor.java:250)
            at org.compiere.server.AlertProcessor.processAlert(AlertProcessor.java:146)
            at org.compiere.server.AlertProcessor.doWork(AlertProcessor.java:64)
            at org.compiere.server.CompiereServer.run(CompiereServer.java:179)

    Effettuando nuovamente il RUN_Env.sh mi accorgo che il CheckDb.sql mi scrive questo...
    MISSING
    ------------------------------------------------------------
    Tablespace INDX does not exist - You need to create it first

    Come devo agire....???
    Cosa ho sbagliato ???

    Sto utilizzando la versione 251f prelevata da compiereitalia.

    Grazie,
    Marco

     
    • marcopb

      marcopb - 2005-03-25

      Ho provato ad eseguire la query  "... a pezzi...
      SELECT Tablespace_Name, COUNT (*) AS Pieces, SUM (bytes)/1024/1024 Free_MB, MAX (bytes)/1024 Largest_kB, ROUND(MAX (bytes) / SUM (bytes),2) * 100 Ratio, SUM (blocks) Free_Blocks, MAX (blocks) Largest_Blocks, ROUND(SQRT (MAX (blocks) / SUM (blocks)) * (100 / SQRT (SQRT (COUNT (blocks)))),2) Fragmentation_Index FROM DBA_Free_Space GROUP BY Tablespace_Name WHERE GROUP.AD_Client_ID=0 AND GROUP.AD_Org_ID=0"

      In pratica non mi torna la clausola WHERE... e come possa funzionare !!??!!

      Qualcuno sa essermi di aiuto ??!!??

      E' normale che il RUN_Env.sh mi avverta cos...

      MISSING
      ------------------------------------------------------------
      Tablespace INDX does not exist - You need to create it first

      Ciao,
      Marco

       
    • marcopb

      marcopb - 2005-03-29

      Non so se sto prendendo la strada giusta... ma prima di rifare tutto da capo... vorrei provare ancora...

      Poiche' la procedura CheckDB.sql mi avverte che "Tablespace INDX does not exist"...
      e' sufficiente con il seguente comando creare il tablesapce in questione...???
      connect / as sysdba
      CREATE TABLESPACE "INDX" LOGGING DATAFILE '/u01/app/oracle/oradata/test/indx01.dbf' SIZE 100M REUSE AUTOEXTEND ON NEXT 1024K MAXSIZE 51200K EXTENT MANAGEMENT LOCAL AUTOALLOCATE;
      Non sono davvero pratico di Oracle...

      Grazie,
      Marco

       
    • marcopb

      marcopb - 2005-03-29

      Per adesso ho risolto... in questo modo...

      Ho droppato l'utente compiere...
      Ho rimosso la directory jboss...
      Ho starato Compiere252b1
      Ho aggiunto il tablespace INDX xhe non mi ritrovavo eseguendo da utente oracle:
      sqlplus /nolog
      connect / as sysdba
      CREATE TABLESPACE "INDX" LOGGING DATAFILE '/u01/app/oracle/oradata/test/indx01.dbf' SIZE 100M REUSE AUTOEXTEND ON NEXT 1024K EXTENT MANAGEMENT LOCAL AUTOALLOCATE;
      Ho eseguito RUN_Setup.sh
      Ho eseguito RUN_ImportCompiere.sh
      Ho eseguito RUN_Server2.sh (e finalmente e' andato tutto a posto)
      Da un altro terminale ho eseguito RUN_Compiere2.sh
      e ho cominciato a vedere finalmente le funzionalita' di Compiere....

      Il passo successivo sara' quello di inserire la traduzione italiana e prima possibile dare un'occhiata ai tools di Compilo.

       
    • Marco LOMBARDO

      Marco LOMBARDO - 2005-03-31

      Bene!!!! :-)

      Mar
      Compilo subAdministrator
      compilo.sf.net

       
    • marcopb

      marcopb - 2005-04-01

      Ciao Marco...
      ho letto tutto il tuo CV su nn...
      Complimenti... ed anche per il tuo grande spirito di altruismo.

      Adesso l'ho addirittura installato su due macchine... una qui in ufficio (per test) ed una presso il consorzio che dovra' utilizzarlo.

      So programmare (C e PRO*C)... ma per quanto riguarda gestionale e commerciale... ho sempre avuto una forte repulsione.... Ora invece mi ci devo avvicinare per forza... il consorzio e' di mio padre e vorrei riuscire a svincolarli dalla piattaforma MS e indirizzarli verso il mondo open source... per quanto possibile.

      Spero di esserti di aiuto il prima possibile.
      Questo forum.. mi sembra un po' "poco forum" :)))
      molti problemi di installazione aperti... ma poi' lasciati li... irrisolti.

      Vabbe'...
      per chi leggera' in futuro....
      Io ho installato Compiere con Fedora Core 3 e Oracle 10g 10.1.0
      Problematiche riscontrate:
      installazione di jsdk 1.4.2...
      (http://forum.java.sun.com/thread.jspa?threadID=571177&messageID=2827642)
      Risolto installando il fix da questa pagina http://www.cit.buffalo.edu/linux/java.html
      e poi mettendo a posto i link simbolici presenti sotto /etc/alternatives marcati in rosso... che puntano ad una directory java sbagliata...
      E' sufficiente il comando ll rm* ja* per rendersi conto.
      ln -s --force /usr/java/product_non_mi_ricordo_il_path/java java
      e cosi' via per ogni link sbagliato.
      L'installazione di default di Oracle 10g 10.1.0 (io ho installato la Standard Edition e senza database di prova) non crea invece il tablespace INDX.
      Prima del RUN_ImportCompiere.sh.... ho risolto dando il comando da utente oracle:
      sqlplus /nolog
      connect / as sysdba
      CREATE TABLESPACE "INDX" LOGGING DATAFILE '/u01/app/oracle/oradata/test/indx01.dbf' SIZE 100M REUSE AUTOEXTEND ON NEXT 1024K EXTENT MANAGEMENT LOCAL AUTOALLOCATE;
      dove il mio database e' ovviamente test ed il path e' il mio path di installazione.

      A presto,
      Marco

       
      • Alessandro Riolo

        > Io ho installato Compiere con Fedora Core 3
        > e Oracle 10g 10.1.0

        Curiosit, ma l'installazione di quella ciofeca di dbconsole (http://x:5500/em) funziona con FC3? Fino ad ora mi  capitata soltanto un'installazione corretta (su un XP Pro sp2), per il resto tutte alla malora .. Ho risolto installando il vecchio EM in Java (si trova nel CD client), ma vorrei tanto capire se la sfiga si accanisce su di me, o se proprio hanno cannato tutte le distribuzioni ..

        --
        ale
        http://www.sen.it

         
    • marcopb

      marcopb - 2005-04-04

      Ciao Ale...
      ho letto anche i tuoi interventi e ho visitato il tuo sito... Complimenti anche a te...
      A me su entrambe le macchine con FC3 e Oracle 10.1.0 ha funzionato.
      In una in particolare in cui ho avuto la necessita' di droppare l'utente ho voluto ripetere l'installazione da capo di Oracle.
      Quindi al runInstaller ho fatto disinstallare i prodotti rilevati e rieseguito il setup.
      Una prima volta mi ha dato problemi sul rilevamento di alcuni task... che non aveva mai dato prima... ma ho pensato molto piu' ad un problema di lettore CD (cosa gia' avvenuta in passato con altri CD).
      Ho pulito il supporto... annullato tutto e rifatto il setup.
      E tutto e' andato liscio.
      L'em funziona a dovere.

      Ciao,
      Marco

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks