Cannot Connect to Client [PLEASE HELP}

  • GusG

    GusG - 2006-01-03

    {Sorry originally posted in General board)

    Hi All,

    I am new to Compiere and have been struggling to get it installed for the past several weeks.  It appears to be a product that we can use but I am having problems crop up at every turn.  I hope that some/one of you can help me resolve this.

    Background info:
    OS:     Windows Server 2003
    Oracle: 10g Release 2
    Java:    1.5.0_06_b05
    Compiere: 2.5.3b

    ... Fron Run_env.bat ...
    COMPIERE_HOME        = C:\Compiere2
    JAVA_HOME            = C:\PROGRA~1\Java\jdk1.5.0_06
    COMPIERE_DB_URL      = jdbc:oracle:thin:@//dev1:1521/erp
    Database ...
    COMPIERE_DB_USER     = compiere
    COMPIERE_DB_PATH     = oracle
    .. Oracle specifics
    COMPIERE_DB_NAME      = erp

    I have installed and re-installed, without problems, all applications and have finally been able to see the initial screen using: http://dev1/compiere.html.

    When attempting the "WebStart" application I am able to get to the application test screen where I can successfully connect to the application server but always fails to connect to the DB.  I can, however, only connect to the application/data via the beta web browser.

    After days of googling for answers I have tried many possible modifications to various files and still no-go.  Some of these modifications include the problem with resolving from localhost in the windows\win32\drivers\etc\host..  Also, the review of the TNSNames.ORA and others.  All TNSpings are positive as are all the SQLPlus commands.

    And, for the life of me I cannot get this function from the WebStart comand.  It continues deny database access since it cannot connect to the DB.  If I try and connect even with the DB test error I receive an error "Database not found" in red at the bottom of the Compiere Login window..

    Please can someone give me a list of hints as to how to resolve this.  I am about to pull out the remainder of my thinning hair!!

    Thank You,

    • Gaurav Kumar

      Gaurav Kumar - 2006-03-20

      I also faced a similar problem. The problem generally occurs, since you are not able to connect to the client.

      DO the following steps:
      1/ Set the JDK_HOME
      2/ Set the COMPIERE_HOME
      3. Check that you dont have any other JDK version, by giving 'java -version'
      4/ Remove if you have any other JDK except 5.0
      5/ Now go to %COMPIERE_HOME%\ 6/ del *.Properties
      6/ RUN_setup
      7/ Complete the information and save after doing the test
      8/ go to %COMPIERE_HOME%\utils
      9/ RUN_ENV
      10/ There will be an error in the last step
      11/ RUN_DBRestore
      12/ Now again check, RUN_ENV
      13/ Now give RUN_server2.bat
      14/ Click on Compiere icon on desktop
      15/ Now check if everything is ok, by clicking on the button provided at the right side of the first text box from the top.
      16/ Check the database connection.
      17/ Now give username/password and click ok
      18/ Select the Role and click ok
      19/ You are ready to go.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks