Compiere server planté

James Web
2006-08-11
2013-05-02
  • James Web

    James Web - 2006-08-11

    Bonjour,
    suite à une coupure de courant, mon serveur (un pc sur suse), compiere ne démarre plus (ou plus précisemment probablement pas complétement) Ni l'accès en client, ni le webstore ne sont accessibles, tout est donc bloqué. Comme je ne sais pas par où commencer pour cherche la cause, je dépose ici ce post. Histoire de savoir quel log examiner et surtout, comment l'interpréter.

     
    • steven

      steven - 2006-08-11

      As tu jeter un coup d'oeil à la log JBoss ?

      Compiere2/jboss/server/compiere/log

       
    • James Web

      James Web - 2006-08-11

      Je peux y trovuer cela, dans un log daté, c'est bien cela ?
      A noter que le démarrage de Compiere est devenu anormalement lent avant de libérer le shell ?!

      -------------------------------

      *** 2006-08-11 10:34:38.684 Compiere Log (CLogFile) ***
      10:34:38.682 Compiere.startup: Compiere(r) Release 2.5.3b_2006-01-20 - Smart ERP & CRM - (c) 1999-2006 Compiere (r); Implementation: Custom 20060524-1213 - Unsupported
      10:34:38.684 Compiere.startup: /erp/compiere - Java HotSpot(TM) Server VM 1.5.0_06-b05 - Linux 2.6.5-7.97-default unknown
      10:34:38.686 Ini.loadProperties: /erp/compiere/Compiere.properties #29

      *** 2006-08-11 15:21:23.852 Compiere Log (CLogFile) ***

       
    • James Web

      James Web - 2006-08-11

      Sorry, je me suis trompé de directory, j'ai mis la main sur le log avec sa date mais ne peut le poster ici, trop long :-|

       
    • James Web

      James Web - 2006-08-11

      Voici juste la fin du server.log (extrait)

      _____________________________

      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@8afe8988 { url=file:/erp/compiere/jboss/server/compiere/deploy/compiereApps.ear }
        deployer: org.jboss.deployment.EARDeployer@1e6e305
        status: Deployment FAILED reason: URL file:/erp/compiere/jboss/server/compiere/tmp/deploy/tmp65039compiereApps.ear-contents/compiereApps.war/ deployment failed
        state: FAILED
        watch: file:/erp/compiere/jboss/server/compiere/deploy/compiereApps.ear
        altDD: null
        lastDeployed: 1155302546001
        lastModified: 1155302542000
        mbeans:

      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.web.deployment:war=compiereApps.war,id=735742914
        State: FAILED
        Reason: org.jboss.deployment.DeploymentException: URL file:/erp/compiere/jboss/server/compiere/tmp/deploy/tmp65039compiereApps.ear-contents/compiereApps.war/ deployment failed

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.web.deployment:war=compiereApps.war,id=735742914
        State: FAILED
        Reason: org.jboss.deployment.DeploymentException: URL file:/erp/compiere/jboss/server/compiere/tmp/deploy/tmp65039compiereApps.ear-contents/compiereApps.war/ deployment failed

      2006-08-11 15:41:00,309 DEBUG [org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread] Notified that enabled: true
      2006-08-11 15:41:00,309 DEBUG [org.jboss.deployment.scanner.URLDeploymentScanner] Started jboss.deployment:type=DeploymentScanner,flavor=URL
      2006-08-11 15:41:00,310 DEBUG [org.jboss.system.ServiceController] Starting dependent components for: jboss.deployment:type=DeploymentScanner,flavor=URL dependent components: []
      2006-08-11 15:41:00,654 DEBUG [org.jboss.deployment.MainDeployer] End deployment start on package: jboss-service.xml
      2006-08-11 15:41:00,654 DEBUG [org.jboss.deployment.MainDeployer] Deployed package: file:/erp/compiere/jboss/server/compiere/conf/jboss-service.xml
      2006-08-11 15:41:00,656 DEBUG [org.jboss.web.tomcat.tc5.Tomcat5] Saw org.jboss.system.server.started notification, starting connectors
      2006-08-11 15:41:00,942 INFO  [org.apache.coyote.http11.Http11Protocol] Starting Coyote HTTP/1.1 on http-192.168.2.200-80
      2006-08-11 15:41:01,098 INFO  [org.apache.jk.common.ChannelSocket] JK: ajp13 listening on /192.168.2.200:8009
      2006-08-11 15:41:01,402 INFO  [org.apache.jk.server.JkMain] Jk running ID=0 time=0/353  config=null
      2006-08-11 15:41:01,419 INFO  [org.apache.coyote.http11.Http11Protocol] Starting Coyote HTTP/1.1 on http-192.168.2.200-443
      2006-08-11 15:41:01,433 INFO  [org.jboss.system.server.Server] JBoss (MX MicroKernel) [4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)] Started in 19m:20s:985ms

       
    • OpenSource

      OpenSource - 2006-08-14

      Il faut voir si Oracle est bien démarré,

       
    • Theo de Brouwer

      Theo de Brouwer - 2006-09-13

      Est-ce que tu as refait un run_setup ? A mon sens, cela devrait résoudre ton problème.
      Théo

       
    • MFOUKA

      MFOUKA - 2007-05-24

      Bonsoir,
      J'ai ce pb de configuration du serveur compiere sur la partie qui suit:
      database server : 8080
      database name : 8080.compiere.org
      database port : 1521
      database user : compiere
      mail server : 8080 mais application server : 8080 marche sans pb.
      voici le message affiché sur le terminal:

      17:44:49.933 Config.test: OK: JavaHome=/usr/local/bin/j2sdk1.4.2_08 [28]
      17:44:49.933 Config.test: OK: Version=1.4.2_08 [28]
      17:44:49.934 ConfigurationData.testCompiere: OK: CompiereHome = /uo1/app/Compiere2 [28]
      17:44:49.934 KeyStoreMgt.<init>: /uo1/app/Compiere2/keystore/myKeystore [28]
      17:44:49.936   KeyStoreMgt.getCertificate: Alias=compiere [28]
      17:44:49.941 ConfigurationData.testCompiere: OK: KeyStore = /uo1/app/Compiere2/keystore/myKeystore [28]
      17:44:49.944 Config.test: OK: AppsServer = 8080/0.0.31.144 [28]
      17:44:49.959 Config.test: OK: Deploy Directory = /uo1/app/Compiere2/jboss/server/compiere/deploy [28]
      17:44:49.960 Config.test: OK: JNPPort = 1099 [28]
      17:44:49.965 Config.test: OK: Web Port = 80 [28]
      17:44:49.973 Config.test: OK: SSL Port = 443 [28]
      17:44:49.993 Config.test: OK: Database Server = 8080/0.0.31.144 [28]
      ===========> ConfigurationData.testPort: Open Socket 8080/0.0.31.144:1521 - Invalid argument or cannot assign requested address [28]
      ===========> ConfigurationData.test: DB Server Port = 1521 [28]
      ===========> ConfigurationPanel$1.finished: Error Database Port
      (DB Server Port = 1521) [12]
      Une aide sera la bienvenue!!!!
      A+

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks