username/password in PG

  • Vincenzo

    Vincenzo - 2002-08-21

    I've installed pgsql and well connected to.
    Now I'm stuck in the login window asking me for a username and password that are not present in the db.

    I know that the porting is not complete yet, but can someone tell me in which table/fields I can put username and password manually, please?

    Thank you in advance

    • jaume teixi

      jaume teixi - 2002-08-21

      Jorg, Pg fans are waiting for a new porting status.

      Alivin, currently only is an empty table/schema for Pg, no seed data, please read my previous message on the topic

      • Vincenzo

        Vincenzo - 2002-08-21

        Yes I know that at the moment the only working db is Oracle.
        I don't want push developers to much because I really appreciate their work.

        My question is quite simple: when I try to login as "System" I'm refused because there are no data in the db, I just would insert manually one record somewhere in the db to have access in Compiere.
        Looking at database tables the right one seems to be "ad_user", can anyone confirm that?

        Probably it's unuseful but is a step ahead :^)


        • Toni Mueller

          Toni Mueller - 2002-08-21

          Without looking, but you know how to get access to some
          random Postgresql data base on your system when you
          are the administrator?

          I'd just try to override any access controls that might be
          in place until I've taken a good look around...

    • Jean-Michel POURE

      This is a common PostgreSQL configuration issue. When you connect from jdbc, you need the following settings :

      1) add you host in /var/lib/pgsql/data/pg_hba.conf
      2) allow socket_connection in > /var/lib/pgsql/data/

      Jean-Michel POURE

      • Vincenzo

        Vincenzo - 2002-08-28

        >This is a common PostgreSQL configuration >issue. When you connect from jdbc, you need the >following settings :

        >1) add you host in /var/lib/pgsql/data/pg_hba.conf
        >2) allow socket_connection in
        > /var/lib/pgsql/data/

        >Jean-Michel POURE
        Can you explain more, please?
        The username/password that Compiere ask me (docs says System/system is the default) is needed to access the "application" Compiere, right? I means that the program checks my username/password comparing it whit something stored in the database.


        the username/password I'm asked for is the Postgres one, i.e. the one one I use to access the database?

        • Stephan Wienczny

          I've got the same problem.
          You don't need to change /var/lib/pgsql/pg_hba.conf if you run compiere on the same computer. Then you must enter 'localhost' as database server.
          My prob is that the configuration tests are working but when I try to log in on the my compiere username and password are not correct. I tryed adding the standards in the docs to the users of my database but it isn't working.

          • Vincenzo

            Vincenzo - 2002-09-30

            The problem with PG at the moment seems to be only one: the absence of a dump of data. There is only an empty dump (unuseful).

            Unfortunately I haven't Oracle to do it by myself, but i'm downloading its 3CD. So I hope to post my dump as soon as possible.


            • Gordon Kerr

              Gordon Kerr - 2002-10-01

              > So I hope to post my dump as soon as possible.

              thank you!  this is the only thing holding me back.

            • Stephan Wienczny

              If you have got it could you please upload a dump?

              • Vincenzo

                Vincenzo - 2002-10-05

                >If you have got it could you please upload a dump?

                I haven't a dump yet, sorry.

                I'm new on Oracle, trying to install and configuring it just for Compiere.
                That's the reason why I would support PG port.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks