IndexOutOfBoundsException after HangUp

  • Richard Gennaro

    Richard Gennaro - 2007-05-21

    After a Winodws HangUp I can't connect anymore to CompiereClient.
    When I log in as SystemAdministrator (and only in this case!!!) I receive the following stacktrace:
    Compiere starting: org.compiere.apps.AMenu - java.lang.IndexOutOfBoundsException: Index: 12, Size: 6

    java.lang.IndexOutOfBoundsException: Index: 12, Size: 6

    at java.util.ArrayList.RangeCheck(

    at java.util.ArrayList.remove(

    at org.compiere.model.MTree.loadNodes(

    at org.compiere.model.MTree.<init>(

    at org.compiere.grid.tree.VTreePanel.initTree(

    at org.compiere.apps.AMenu.<init>(

    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(

    at java.lang.reflect.Constructor.newInstance(

    at java.lang.Class.newInstance0(

    at java.lang.Class.newInstance(

    at org.compiere.Compiere.main(

    at com.audaxis.compiere.Main.main(

    It seemes to me like cache can't reset session hanged up...

    DB: Oracle 9i
    OS: Windows 2000 Server SP4
    Compiere: 252a
              + Audaxis Localisation for France
              + 4Layers Localisation for Italy

    I don't know how to reproduce it... I just know that suddenly Windows
    hanged up.
    I was working on Compiere logged in as SystemAdminstrator with 4 Wiundows
    When Windows restarted I could not log in as System Administrator
    It only happens as SystemAdministrator and only on schema I was working
    If I switch to the Production Schema, everything works fine.
    So I think that there is some cache/session table to reset, or something
    like that, but I don't know what to do...
    I tried deleting records from AD_Session and AD_PInstance with update date
    = yestarday but nothing changed...
    I also tried to overwrite with an older one....
    BTW, where is Compiere cache stored ?

    Please Help, I'm talking about a Production Environment !!!!!!!!

    • Richard Gennaro

      Richard Gennaro - 2007-05-21

      I fixed it!
      I had to remove records created in AD_TreeNodeMM....


Log in to post a comment.