ORA-00942: table or view does not exist

2008-09-10
2013-05-02
  • publicly_displayed_name

    Hello,

    I'm trying to install Compiere 3.1.0 on a Debian Linux 4.0 instance running Oracle 10g XE. During the installation I get the error:

    -----------> ConfigOracle.getWebStores: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist
    [15]
    12:11:55.116 ConfigOracle.test: OCI Test Skipped [15]

    I had to manually create the 'compiere' user in Oracle. The installation instructions did NOT suggest doing this, and the installer would fail getting this far unless I created this user myself.

    This probably says something about the installation instructions...

    If I continue the installation ignoring this error I run into more trouble:

    12:12:14.785   DB_Oracle.getDataSource: DB_Oracle[null-CompiereDS,ImplCache=true,MaxStmts=50] [12]
    ===========> DB.executeUpdate: ALTER TABLE AD_System MODIFY Summary NVARCHAR2(2000) [null] [12]
    java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist
    ; State=42000; ErrorCode=942
            at oracle.jdbc.driver.SQLStateMapping.newSQLException(SQLStateMapping.java:91)
            at oracle.jdbc.driver.DatabaseError.newSQLException(DatabaseError.java:112)
            at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:173)
            at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:455)
            at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:413)
            at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:1030)
            at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:194)
            at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:947)
            at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1222)
            at oracle.jdbc.driver.OracleStatement.doScrollExecuteCommon(OracleStatement.java:4206)
            at oracle.jdbc.driver.OraclePreparedStatement.doScrollPstmtExecuteUpdate(OraclePreparedStatement.java:9472)
            at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3379)
            at oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java:3462)
            at oracle.jdbc.driver.OraclePreparedStatementWrapper.executeUpdate(OraclePreparedStatementWrapper.java:1349)
            at org.compiere.util.CPreparedStatement.executeUpdate(CPreparedStatement.java:221)
            at org.compiere.util.DB.executeUpdate(DB.java:854)
            at org.compiere.util.DB.executeUpdate(DB.java:761)
            at com.compiere.client.ComponentPanel.g(Unknown Source)
            at com.compiere.client.ComponentPanel.a(Unknown Source)
            at com.compiere.client.ComponentPanel.init(Unknown Source)
            at org.compiere.install.Setup.propertyChange(Setup.java:226)

    -----------> DB.saveError: DBExecuteError - ORA-00942: table or view does not exist
    [12]

    Has anyone seen this before ? This can't be normal.

     
    • vinay kurudi

      vinay kurudi - 2008-10-22

      Yes, I am seeing same issue. I am trying to install compiere on windows XP using Oracle 10gR2. I am getting following error:
      12:26:11.968 ConfigOracle.test: OCI Test Skipped [13]
      -----------> ConfigurationData.testPort: Open Socket vinay/192.168.1.6:25 - Connection refused: connect [13]
      12:26:12.968 ConfigurationData.testMailServer: SMTP Server NOT available [13]
      -----------> ConfigurationData.testPort: Open Socket vinay/192.168.1.6:110 - Connection refused: connect [13]
      12:26:13.984 ConfigurationData.testMailServer: POP3 Server NOT available [13]
      -----------> ConfigurationData.testPort: Open Socket vinay/192.168.1.6:143 - Connection refused: connect [13]
      12:26:14.984 ConfigurationData.testMailServer: IMAP4 Server NOT available [13]
      -----------> ConfigurationData.testMailServer: No active Mail Server [13]
      -----------> ConfigurationData.testMail: Not verified EMail = info@vinay [13]
      12:33:23.171 ConfigVMSun.test: OK: JavaHome=C:\Program Files\Java\jdk1.6.0_10 [14]
      12:34:32.390 ConfigVMSun.test: OK: Version=1.6.0_10-rc2 [14]
      12:34:32.390 ConfigurationData.testCompiere: OK: CompiereHome = C:\Compiere2 [14]
      12:34:32.390 KeyStoreMgt.<init>: C:\Compiere2\keystore\myKeystore [14]
      12:34:32.390   KeyStoreMgt.getCertificate: Alias=compiere [14]
      12:34:32.390 ConfigurationData.testCompiere: OK: KeyStore = C:\Compiere2\keystore\myKeystore [14]
      12:34:32.390 ConfigTomcat.test: OK: AppsServer = vinay/192.168.1.6 [14]
      12:34:32.390 ConfigTomcat.test: OK: Deploy Directory = C:\Program Files\Apache Software Foundation\Tomcat 5.5 [14]
      12:34:32.390 ConfigOracle.test: OK: Database Server = vinay/192.168.1.6 [14]
      12:34:32.390 ConfigOracle.test: OK: Database Port = 1521 [14]
      12:34:32.406 ConfigOracle.test: OK: Connection = jdbc:oracle:thin:@//vinay:1521/orcl [14]
      12:34:32.406 ConfigOracle.test: OK: Database System User orcl [14]
      12:34:32.421 ConfigOracle.test: OK: Database User = mycompiere [14]
      -----------> ConfigOracle.getWebStores: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

      ------------------------------------------
      I am really not sure which table or view do I need to create? Is there any schema that I need to create?

      Please do let me know if anyone has solved this issues or has any clue about this issue. I even tried to install without creating database user and (expectedly) it is able to identify that use is invalid. It gives following error:
      ORA-01017: invalid username/password; logon denied

      ------------------------------

       
    • Gulshani Agivetova

      Hi!

      Before starting the installation of Compiere you should create a user compiere/compiere in database and assign him unlimited quota on tablespace (eg. create user compiere identified by compiere quota unlimited on users;)
      Also grant dba roles to this user(eg. grant dba to compiere)

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks