Jarsigner.exe not found

Rick Davey
  • Rick Davey

    Rick Davey - 2009-02-06

    I get the following error:
    13: C:\Compiere\build.xml:362: Execute failed: java.io.IOException: Cannot run program "jarsigner.exe": CreateProcess error=2, The system cannot find the file specified
    14: Total time: 24 seconds
    24: ** Finished

    I do have jarsigner.exe in the bin folder.  Here are the variables from the Compiere env properties file
    COMPIERE_JAVA_OPTIONS=-Xms128M -Xmx1024M -XX\:MaxPermSize\=128m
    JAVA_HOME=C\:\\Program Files\\Java\\jdk1.6.0_12

    I seem to have the env variables set right.  Run this serveral times to check it, always says it cannot find the jarsigner.exe file.

    What folder is it looking for???

    In my case I have the jarsigner.exe in the bin folder under the C\:\\Program Files\\Java\\jdk1.6.0_12  

    • Eldir Tomassen [ActFact B.V.]

      Did you try adding the C\:\\Program Files\\Java\\jdk1.6.0_12\bin folder to the system path?
      Can you run jarsigner from the command prompt?

  • mizztabx

    mizztabx - 2010-01-12

    I had the indentical problem!

  • ad heine

    ad heine - 2010-03-26

    Hi I'm a newbie. I had the same problem installing Compiere on Windows XP with Oracle XE. I've installed the Java  JDK 6 update 18 (released January 2010), but I noticed that the Compiere community edition was released in 2008.

    @ eldir, I tried adding the bin folder to the system path as suggested above, but the Compiere installer wouldn't accept that setting. I do not know how to run jarsigner from the command prompt.

    log file:
    03:29:19.937 ProgressPanel.publish: BUILD FAILED
    03:29:19.937 ProgressPanel.publish: C:\Compiere2\build.xml:369: Execute failed: java.io.IOException: Cannot run program "jarsigner.exe": CreateProcess error=2, The system cannot find the file specified
    03:29:19.937 ProgressPanel.publish: Total time: 3 minutes 35 seconds
    03:29:19.937 ProgressPanel.publish: ** Finished
    03:29:19.953 ProgressPanel.finished: Worker success=false

  • aladin

    aladin - 2010-03-29

    I used to occasionally get a "jarsigner" error when I installed different versions of Compiere on Windows XP & Oracle XE. One of the tech guys I worked with couldn't find the problem, but the way I resolved was:
    - Delete the Compiere2 folders
    - Delete the Compiere database in OracleXE
    - Removed the System variables and /Document and Settings/<user>/properties files
    - Reinstalled Compiere again very slowly and carefully

    This did worked because I never got the problem again, but not sure why!

  • chrisranjana.com

    Once you have set the 2 variables namely JAVA_HOME and COMPIERE_HOME close the old DOS prompt and open a new DOS prompt and then type the RUN_setup command  with full path like


    and not just RUN_setup. It worked like a charm for me

  • Anonymous - 2010-12-28

    Under system variables
    add C:\Program Files\Java\jdk1.6.0_12 to JAVA_HOME
    add C:\Program Files\Java\jdk1.6.0_12 to your path statement as well (make sure you separate paths by a ;


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks