#25 ComboBox Selection with mouse does not work after Popup menu

X_2.4.0
closed-fixed
nobody
UI: Swing (185)
5
2002-02-01
2001-11-13
Jorg Janke
No

In some combo boxes it is very hard to select an item
via the mouse - just via keyboard keys.

It seems that these are only combo boxes, where a
change in selection triggers some actions
(dependencies, callouts, ..).

Discussion

  • Jorg Janke

    Jorg Janke - 2001-11-14

    Logged In: YES
    user_id=87038

    Seems to be incosistent. Sometimes no issues at all.

     
  • Jorg Janke

    Jorg Janke - 2001-11-16
    • priority: 7 --> 3
    • assigned_to: jjanke --> nobody
     
  • Jorg Janke

    Jorg Janke - 2001-11-16

    Logged In: YES
    user_id=87038

    Now stable for a few days.

     
  • Jorg Janke

    Jorg Janke - 2001-11-18
    • labels: 367389 -->
     
  • Jorg Janke

    Jorg Janke - 2001-11-18
    • milestone: 154478 -->
     
  • Jorg Janke

    Jorg Janke - 2001-11-18
    • milestone: --> X_2.4.0
     
  • Jorg Janke

    Jorg Janke - 2001-11-22
    • labels: --> UI: Swing
    • status: open --> closed-works-for-me
     
  • Jorg Janke

    Jorg Janke - 2001-11-28

    Logged In: YES
    user_id=87038

    ===> Bug in Swing Library in 1.4.0 beta 3 b84
    - filed Bug report with Sun #136404

    The combobox selection via mouse is disabeled, after you
    right-click on a popup menu!

     
  • Jorg Janke

    Jorg Janke - 2001-11-28
    • priority: 3 --> 5
    • summary: ComboBox Selection with mouse dificult --> ComboBox Selection with mouse does not work after Popup menu
    • status: closed-works-for-me --> pending-accepted
     
  • Jorg Janke

    Jorg Janke - 2001-11-28
    • status: pending-accepted --> open-accepted
     
  • Jorg Janke

    Jorg Janke - 2001-11-28

    Logged In: YES
    user_id=87038

    The issue is fixed in 1.4.0_rc1

     
  • Jorg Janke

    Jorg Janke - 2002-02-01

    Logged In: YES
    user_id=87038

    Fix confirmed.

     
  • Jorg Janke

    Jorg Janke - 2002-02-01
    • status: open-accepted --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks