#16 Bug in post_edit.php. Date-format wrong.

To_Fix_in_v1.1
closed-fixed
nobody
5
2009-07-14
2006-01-02
colione
No

When you check the site that listts your posts in the
admin-area your-posts are listed like: 12/31/05
15:20:00 For the 31 october. However, when i want to
edit the post and check the date there it is listed
like this: 31/12/2005 15:20. And this will make the
post appear incorrctly on the frontpage. (E.g if i save
the post with the: 31/12/2005 it will appear as a date
in july 2008).

Discussion

  • colione

    colione - 2006-01-02
    • milestone: --> To_Fix_in_v1.1
    • labels: --> Application Bug
     
  • Mark Wallis (aka serialmonkey)

    Logged In: YES
    user_id=342445

    Can you please tell me what timezone your CoMoblog server it configured in -
    most likely this is an issue with PHP date parsing so I'll reconfigure my test
    server to match yours.

     
  • Mark Wallis (aka serialmonkey)

    • assigned_to: nobody --> markwallis
    • status: open --> pending
     
  • colione

    colione - 2006-01-03
    • status: pending --> open
     
  • colione

    colione - 2006-01-03

    Logged In: YES
    user_id=1413733

    Hmm, could it be because of my own swedish.inc.php in the
    language folder. It contains the following:

    //
    // LOCALIZATION
    //
    // Refer to 2 digits codes in
    http://www.w3.org/WAI/ER/IG/ert/iso639.htm
    //

    $SET_LOCALE = 'sv';

    //

    //
    // DATE FORMAT
    //
    // uncomment the format that best suits your language
    // or edit string formats according to
    http://www.php.net/strftime
    //

    $CAL_DATE_FORMAT = '%d/%m/%Y'; // dd/mm/yyyy
    //$CAL_DATE_FORMAT = '%Y/%m/%d'; // yyyy/mm/dd

    $POST_DATE_FORMAT = '%A, %d %B'; // i.e.
    Sunday, 1 October
    //$POST_DATE_FORMAT = '%A, %B %d'; // i.e.
    Sunday, October 1

    //

    And my server is most likely set to swedish, i don't
    administate it but that's a qualified guess :)

     
  • Mark Wallis (aka serialmonkey)

    Logged In: YES
    user_id=342445

    Don't think it's an issue with your localisation file as that is only used when
    displaying posts to your users - not in the admin section.

    It's abit of a worry that you are seeing two different date display formats on
    the manage_posts and post_edit screens - especially since they are using
    almost the exact same format options.

    What version of CoMoblog are you running - plain straight version 1.0 or are
    you keeping up to date with CVS ? I just want to confirm this isn't something
    I've already fixed as I have commited changes around this area and I can't see
    how the current code can cause what you are seeing.

     
  • Mark Wallis (aka serialmonkey)

    • status: open --> pending
     
  • colione

    colione - 2006-01-05

    Logged In: YES
    user_id=1413733

    I updated a while ago, will do a new update.

    It seems to work after a cvs-update. Sorry, that i didn't
    update before. :)

     
  • colione

    colione - 2006-01-05
    • status: pending --> open-accepted
     
  • Mark Wallis (aka serialmonkey)

    • status: open-accepted --> closed-fixed
     
  • Mark Wallis (aka serialmonkey)

    Logged In: YES
    user_id=342445

    Phew ! Glad to hear it.

    Also, be careful keeping uptodate with CVS - if you are just getting the latest
    version of each file you are going to be missing any DB changes that occur
    between versions.

     
  • Mark Wallis (aka serialmonkey)

    • assigned_to: markwallis --> nobody
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks