Python imaging not found

Help
Superken7
2007-03-01
2013-05-23
  • Superken7

    Superken7 - 2007-03-01

    Hello, i run debian unstable, and have python-imaging installed
    however, when comix is run, the Image import apparently fails and the following message is displayed:

    $ comix
    /usr/bin/comix:6523: FutureWarning: hex/oct constants > sys.maxint will return positive values in Python 2.4 and up
      pixbuf.fill(0xffffffff)
    Python Imaging Library 1.1.4 or higher is required to run Comix.
    No version of the Python Imaging Library was found on your system.

    although i do have those libraries installed
    $ dpkg -l | grep python-imaging
    ii  python-imaging                   1.1.5-11                       Python Imaging Library

    is that maybe a problem with paths ?
    any help would be appreciated, i am eager to try comix out ;)
    thanks

     
    • Pontus Ekberg

      Pontus Ekberg - 2007-03-06

      Have you installed a newer Python version recently? Usually you have to reinstall Python modules when you upgrade to a new major version (like 2.3 -> 2.4). I'm not sure how dpkg handles things, but I would try to reinstall python-imaging.

       
    • mendizabal

      mendizabal - 2007-03-18

      I have the same error.

      Python Imaging Library 1.1.4 or higher is required to run Comix.
      No version of the Python Imaging Library was found on your system.

      Buy I have it.

      pil-1.1.6-1
      python-2.5-2
      pygtk-2.10.4-1

      I use this comix version:

      comix-3.6.3-1

      It is from the community repository of Arch Linux distro.

      Greetings

       
    • Pontus Ekberg

      Pontus Ekberg - 2007-03-18

      Have you recently upgraded Python? Do you have more than one Python version installed?

       
    • mendizabal

      mendizabal - 2007-03-19

      I have only one version of python installed: python 2.5-2

      Greetings

       
    • Pontus Ekberg

      Pontus Ekberg - 2007-03-19

      Well, something has gone wrong with the PIL install. You can try this to make sure:

      * Open up a Python interpreter with the command "python".

      * Type in "import Image" and press Enter.

      If Python can't find PIL you should get an error message, if it can it will give no output at all.

      I would try to reinstall PIL if you haven't done that already. If that doesn't help I'm not sure what you should do, please consult your distribution's forums/mailing lists/whatever for clues on what might have gone wrong with the install.

       
    • mendizabal

      mendizabal - 2007-03-20

      jeje now it works. Today there was an update on the PIL package. Now it works perfectly. Maybe that there was a problem with the package building or something like that.

      Anyway, your program works very well in Arch Linux. Congratulations for an excellent program.

      Greetings.

       
    • Pontus Ekberg

      Pontus Ekberg - 2007-03-20

      Good to hear it works.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks