help to sign com0com

  • Anonymous - 2011-08-17

    I know there are signed versions of com0com out there, but my firm has a VeriSign certificate, and would like to use it to sign com0com.

    So. I have builded com0com from source code. Then I have created a file using inf2cat. I have signed the com0com.sys and the file using the VeriSign certificate.

    I have been using Windows Win7 Free Build Environment as administrator.

    I used Signtool verify to verify the signatures on the .cat and .sys file

    Now: executing "C:\Program Files\NSIS\makensis.exe" /V2 C:\com0com\NSIS\install.nsi  do create the wanted setup.exe file, but when I run it, I get a warning telling me that the driver software I am attempting to install does not have a valid signature that verifies who published it…

    What am I not doing/doing wrong?

    Malin Edvardsen

  • Vyacheslav Frolov

    If you use file install.nsi from then note it does not package

  • Anonymous - 2011-08-18

    Aha. Do you have some older/newer versions where it does? Or must I figure it out myself =P
    Thank you for quick answer btw! =D

  • Vyacheslav Frolov

    Current CVS version does it.

  • Anonymous - 2011-08-18

    It worked like a charm! Thank you =D

  • Anonymous - 2011-08-18

    It looks like I was a bit to quick to say that it worked =/

    When trying to install, first I get a message asking if I want to install the driver software
        Name: Vyacheslav Frolov com0com - serial port …
        Publisher: "my company"

    I also get a window titled "Setup for com0com (PREINSTALL)" where it says "Installed Class {"long number"}"
    Then I get those warnings telling me that the driver software I am attempting to install does not have a valid signature that verifies who published it.

    I understand that these are not really questions about com0com itself, and I really appreciate all the help I get! Sorry for being so bad at this =/

  • Anonymous - 2011-08-18

    Btw: the program is working. (running on windows 7)
    It is just that I have to select
    "Install this driver software anyway"
    tree times while installing, and it looks kind off bad

  • Anonymous - 2011-08-18

    Problem solved =)
    I just needed to add all the .inf files(not just com0com.inf) to amd64 before creating

  • Imran

    Imran - 2011-11-04

    I am following the building instructions of

    1.  Build the driver.
        For example execute in the DDK build environment window:

          cd C:\com0com
          build -wcZ -M 1

        It will create the com0com.sys, setup.dll and setupc.exe files in the
        C:\com0com\&lt;CPU>\ directory, where <CPU> is i386, ia64 or amd64
        and depends from choosen DDK build environment.

    but when i try to build i get the following error.
    Nmake :Fatal Error U1073. Don;t know how to make ..\i386\setup.lib

    can you please help in this regard?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks