I enabled config_hotplug and the kernel compiled and worked fine, but it didn't solve my problem of no /dev/net/tun device file upon modprobing the tun module.  I am not a hotplug or udev guru, I'm a devfs kind of guy, so I may be doing something else wrong.  I decided once I was able to customize the coLinux kernel, instead of modular tun and hotplug nonsence I would just make tun part of the kernel and that fixed it for good.

I am running Gentoo in my coLinux, and they provide an option in /etc/conf.d/rc to tar the contents of the /dev tempfs to be restored at next boot which would also solve the problem if you makedev the /dev/net/tun device yourself.

I would like to know if what I was attempting with hotplug is possible in coLinux and where I went wrong.  If I find the time, I'll boot a test instance and look into it more fully.

Ron Helzer
helzerr@gmail.com

On 9/9/06, George P Boutwell <george.boutwell@gmail.com> wrote:
Let us know how your custom kernel goes...  If you don't experience
too many problems with it enabled, then we can test it and see how it
makes out.

On 9/9/06, Ron Helzer < helzerr@gmail.com> wrote:
> I am in the process of building a custom kernel for use with coLinux to
> enable hotplug support.  I am assuming  that since coLinux prevents
> interaction directly with the hosts hardware, hotplug support was deemed
> unnecessary.
>
> However, devices such as /dev/net/tun need hotplug support to work properly
> with udev.  May I suggest that future coLinux default kernel configurations
> have config_hotplug enabled?

--
George