Hi,

I have solve this problem. It is caused by the network device changed.It can be solved as following:

Edit file /lib/udev/rules.d/75-persistent-net-generator.rules and set a bypass for coLinux in same way as xen or UML does it

======================================================

--- /lib/udev/rules.d/75-persistent-net-generator.rules.orig

+++ /lib/udev/rules.d/75-persistent-net-generator.rules

@@ -23,6 +23,9 @@

 # ignore Xen virtual interfaces

 SUBSYSTEMS=="xen", GOTO="persistent_net_generator_end"

 

+# ignore coLinux virtual interfaces

+DRIVERS=="conet", GOTO="persistent_net_generator_end"

+

 # read MAC address

 ENV{MATCHADDR}="$attr{address}"

======================================================

Remove the file “/etc/udev/rules.d/70-persistent-net.rules”.

 

Please refer: http://colinux.wikia.com/wiki/Fedora11Minimal

 


发件人: Henry Nestler [mailto:henry.ne@arcor.de]
发送时间: 2011年8月19 7:38
收件人: 余松
抄送: colinux-users@lists.sourceforge.net
主题: Re: [coLinux-users] The network does not work ok when run as service, why?

 

On 13.08.2011 19:26, 余松 wrote:



I make a new colinux file system of debian 6.0.2 using debootstrap.

When I start the colinux from command line, the network is ok, the ping is ok.

But when I run the colinux as service, the network does not ping ok. Why?

 


Running from command prompt and as service are different Users under Windows. The MAC is stored in Users registry.
The "automatic" MAC is differ between these boots and udev will rename your interface eth0 into an other, mostly eth1 or eth2.

Please write a unique MAC into your config file.

Or follow the description in the Wiki to not rename the eth0 on different boots:
http://colinux.wikia.com/wiki/Wubi#udev:_renamed_network_interface_eth0_to_eth2
http://colinux.wikia.com/wiki/Fedora11Minimal#udev:_renamed_network_interface_eth0_to_eth1

-- 
Henry N.