and look at the error again,  "error: parameter 'buffer' set but not used [-Werror=unused-but-set-parameter]"
if you don't want to change gcc, maybe you can disable warning as error flag. and try again.

On Sun, Sep 23, 2012 at 9:01 PM, yin sun <sunyin51@gmail.com> wrote:
your error looks like a gcc problem. try use gcc 4.4
since we are building kernel program/device driver, the compiler version/flags is important.
in this case, I think gcc 4.6 never been tested to work. 


On Sun, Sep 23, 2012 at 8:47 PM, Shao Miller <sha0.miller@gmail.com> wrote:
Thanks again.

Here is my scenario:

- Development system for building coLinux and coLinux kernel: Fedora 15
  - GCC ver. 4.6.3
  - MinGW GCC ver. 4.5.3

The 'make' process appears to wish to build particular versions of tools,
but I don't quite understand why.  Why is it that it cannot use whatever
tools I have installed?  After reading doc/building.txt, I still am not
clear on why.

I did download all of the particular versions via 'make download'.  But when
I run 'make', it fails to build the binutils-2.19.1 that was downloaded.
There are a few errors[1], but "fixing" them would seem to be out-of-scope
for coLinux.  So again, can I just use the tools that I have?  I tried
'./configure --gcc-guest-build', but that didn't seem to do the trick.

Thanks for your time, once more.

- Shao

[1]

  --- ERROR LOG /usr/src/colinux-devel/log/build-colinux-25679.err:
  In file included from ../../binutils-2.19.1/libiberty/regex.c:638:0:
  ../../binutils-2.19.1/libiberty/regex.c: In function
‘byte_re_match_2_internal’:
  ../../binutils-2.19.1/libiberty/regex.c:7141:27: warning: variable
‘sdummy’ set but not used [-Wunused-but-set-variable]
  ../../binutils-2.19.1/libiberty/regex.c:7140:22: warning: variable
‘pdummy’ set but not used [-Wunused-but-set-variable]
  ../../binutils-2.19.1/libiberty/regex.c:7476:5: warning: jump skips
variable initialization [-Wjump-misses-init]
  ../../binutils-2.19.1/libiberty/regex.c:5952:12: note: label
‘restore_best_regs’ defined here
  ../../binutils-2.19.1/libiberty/regex.c:5913:16: note: ‘same_str_p’
declared here
  ../../binutils-2.19.1/bfd/compress.c: In function
'bfd_uncompress_section_contents':
  ../../binutils-2.19.1/bfd/compress.c:54:45: error: parameter 'buffer' set
but not used [-Werror=unused-but-set-parameter]
  ../../binutils-2.19.1/bfd/compress.c:54:68: error: parameter 'size' set
but not used [-Werror=unused-but-set-parameter]
  cc1: all warnings being treated as errors
  make[5]: *** [compress.lo] Error 1
  make[4]: *** [all-recursive] Error 1
  make[3]: *** [all] Error 2
  make[2]: *** [all-bfd] Error 2
  make[1]: *** [all] Error 2
  make binutils failed
  make: *** [cross] Error 1

________________________________________
From: yin sun [mailto:sunyin51@gmail.com]
Sent: Sunday, September 23, 2012 22:54
To: Shao Miller
Subject: Re: [coLinux-users] Porting a Kernel

patches are what colinux releases. the build process will download the
original linux kernel code from the kernel official site first.
once you download the svn devel branch. 
./configure
make 
will take care all of these. this topic should be discussed on dev mailing
list.
On Sun, Sep 23, 2012 at 7:25 PM, Shao Miller <sha0.miller@gmail.com> wrote:
Thank you.

I am trying your suggestion.  So far, I have needed bison, patch, flex,
texinfo, texinfo-tex, gettext.  I will see how it all goes.

Is there an official SVN for coLinux Linux source, rather than just patches/
?

- Shao

________________________________________
From: yin sun [mailto:sunyin51@gmail.com]
Sent: Sunday, September 23, 2012 20:15
To: Shao Miller
Cc: colinux-users@lists.sourceforge.net
Subject: Re: [coLinux-users] Porting a Kernel

current colinux kernel is based on 2.6.33.7 not very different from 2.6.38.6
you can try to go through the colinux build process first. once you are
familiar with it, 
you should know how to port a new kernel.
On Sun, Sep 23, 2012 at 2:04 PM, Shao Miller <sha0.miller@gmail.com> wrote:
Good day, folks.

If I was interested in compiling a Linux kernel for use with coLinux, how
might I go about it?  Are there instructions already documented?

I have the Linux source and the coLinux source.  I was planning on reviewing
the items inside coLinux' patch/ directory, then porting those into a branch
in my Linux git repository.  Does that make the most sense?

For the curious, I'm wanting to get Fedora 15's 2.6.38.6-rc1 kernel running
under coLinux so I can port my installation away from VMware and to coLinux.
Fedora 15 is "end-of-life," but oh well.

Thank you for your time.

- Shao


----------------------------------------------------------------------------
--
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://ad.doubleclick.net/clk;258768047;13503038;j?
http://info.appdynamics.com/FreeJavaPerformanceDownload.html
_______________________________________________
coLinux-users mailing list
coLinux-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/colinux-users