Hiya

I decided to get back to this wondrous piece of software, that i used last time around 0.73. I had the original disk image as well as conf file, though i havent got any idea how wrong the comeback would fare.

I planned to use the same layout i used before, two interfaces:

eth0 - pcap-bridged 11.0.0.7/255.255.255.0/broadcast 11.0.0.255/wasnt sure about gateway -> bridged to Microsoft Loopback adapter set to 11.0.0.1/255.255.255.0
both static - as a private link for telnet/xming access;

eth1 - pcap-bridged, dhcp, bridged to ethernet adapter - used for guest internet access.

Host runs winpcap 4.1.1 (with no problems, wireshark works fine).

First discrepancy: http://colinux.wikia.com/wiki/Network > WinPcap > The WinPcap driver > regarding colinux conf, bolded:
"Make sure the mac-address is different from the mac of your regular network interface. If you want to read why, read up on layer 2 networking."

after doing so, i get the following error on colinux boot:

SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth0.

same error for eth1.

My next step was to pass exactly the same mac address as the one on host side i was bridging to. Miraculously, it worked. Both eth0 and 1 got up, eth1 also got ip from dhcp server (router box my whole local network is connected to) and i was able to access internet via eth1.

Unfortunately, same trick didnt work for eth0. I cannot set up the private link. Wireshark on host, when i ping from guest, sees the incoming guest ARP`s (where is 11.0.0.1, asks 11.0.0.7) without any answer. Windows Firewall has no effect on this, tried it enabled, disabled, and with loopback removed from filtering.

I spent hours trying all possible combinations, adding gateways on either side etc... What is more funny, i can easily access guest from other machines on my network, via eth1 (at least it responds to ping and can ping them back) but nothing between host<>guest.

Please help. I will gladly provide all necessary info and respond to any question regarding this issue. I`m this >< close to drop colinux and add new vm to virtualbox, (even though the performance will be pathetic compared to colinux) and waiting for x86-64 version so i could install it on my server box.

Thanks in advance