Thanks Henry,

net start "coPlanet"

worked like a charm.

Cheers,
Mark.

On 11/16/06, Henry Nestler < Henry.Ne@arcor.de> wrote:
Mark Zaloumis wrote:
> I'm running coLinux 0.7.1-hn16 on Windows XP. Here is the output from
> colinux-daemon.exe --status-driver:
>
> C:\coPlanet\coPlanet>colinux-daemon.exe --status-driver
> Cooperative Linux Daemon, 0.7.1-hn16
> Compiled on Sun Jul  9 16:35:25 2006
>
> checking if the driver is installed
> current state: 4 (fully initialized)
> current number of monitors: 0
> current linux api version: 10
> current periphery api version: 20
>
> so it looks like the CoLinuxDriver driver is installed properly.

Ok, it is.

> To install a coLinux service I run the following:
>
> colinux-daemon.exe "@C:\coPlanet\coPlanet\pl.conf" ro root=/dev/sda1
> --install-service "coPlanet"
>
> I tried running with the debugger but I only got the same information
> that is dumped to stdout when I try and start the service from the
> console with:
>
> colinux-daemon.exe --run-service "coPlanet"

Ah, that's wrong.  "--run-service" is an internal to start from inside
the service account only.

You should start the service with typical windows commands:
   net start coPlanet

Or with windows service mannager console (the gui, where you can
start/stop and manage all services).

--
Henry Nestler