I got it to work.
Booted a native linux live CD, the loop device worked, copied everything in to a tar ball then restored it in a new Virtualbox drive.
I don't know if loop device works well on virtualbox when the file being mounted is located in a virtual box file share mount.

I can give better/clearer instructions if anyone is interested.

A note for anyone trying this. I use virtual machines for Symfony web development and have the web app source in my host Vista 64 HDD.
VirtualBox file share did not work very well, I'm having to use smb.

I miss Colinux :o(

Sorry if this msg seems obscure, too much work too little time...
Thanks for the help.

Frank Church wrote:
Why don't you paste the configuration and instructions you are using?
That would be a lot more help'

2009/7/24 GuyBrush <guybrush.mi3@gmail.com>:
I just got a new laptop with vista 64 and I can't downgrade to XP 32 and
run Colinux.
Anyone tried to move from Colinux to virtualbox?

This is what I have tried so far.

* installed kubuntu 9.04 (x86 IIRC) guest in virtualbox using vista 64
as host
* mounted vista shared host folder
* tried to mount ubuntu colinux image located inside the shared folder
using loop device.- This does not work,
the mount command keeps running and returns no output. After a while I
try to kill mount but it also does not work.

I'm trying to copy all the colinux files to a virtualbox image so it can
boot from virtualbox.

Anyone has any ideas?

Thank you!

coLinux-users mailing list