i did perform those checks before posting to the group.

my fstab contains the correct lines. listing the mounts of a running colinux system shows that /dev/shm is indeed mounted.

- mela

On 10/7/05, Henry Nestler <Henry.Ne@arcor.de> wrote:

Mela Custodining wrote:
> Good day,
> Recently I had the chance to use an application, which uses IPC, on
> coLinux. It uses shared memory. I am using the Gentoo 2Gb images. I'm
> using 0.6.3 stable snapshots, WinPCAP-bridges, and using cofs.
> When I run the binaries in coLinux the IPC calls failed, particulary
> shm_init failing with ENOSYS. (I have pshared == 1)
> When I run the binaries on a Shrike machine, the application executes
> properly.
> Before I go out build my own custom vmlinux (as a last resort) I would
> like to ask those knowledgeable than me if the kernel shipped coLinux
> supports IPC. Is rebuilding a new vmlinux the solution to my problems?
> Your inputs would be highly appreciated.
> - mela

Have you mount the shm device?

> mount | grep shm
tmpfs on /dev/shm type tmpfs (rw)

If not, try this before you start your program:
> mount -t tmpfs tmpfs /dev/shm

Henry Nestler