gdm fails, xterm ok: fedora9

  • skeptical

    skeptical - 2008-10-21


    I've mounted Bill Riemers' vnc-configured fedora9.img on 0.7.3 using pcap-bridge and running xming, and get a graphic terminal with xterm.  Network is ok, group-installing Gnome Desktop Environment is successful, but gdm fails to start and I get the following from xorg:

    ------------ /var/log/Xorg.0.log ------------
    Fatal server error:
    xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

    which after reading around a bit I take to mean xorg is trying to connect to the actual video card and not xming.  My gdm configuration (copied from my previous graphically OK  fedora 5 setup):

    -- -------- /etc/gdm/custom.conf ----------



    Not sure what I need to do/undo to this image to get X configured for xming.

    Thanks in advance

    • Dr Bill C Riemers

      As of Fedora7 most of the options in /etc/gdm/custom.conf do not work.  As an additional problem, as of Fedora9 even some of the options in the master configuration file no-longer work.  To work around this, you should in fact find /usr/bin/X is a script that mangles the arguments and calls Xvnc.

      You can test this is working by calling: startx

      This should invoke Xvnc.

      As far as configuration files go, I've pre-installed the correct configuration files on the image, but often after a yum update, the configuration files are overwritten.  In the /root directory you will see a tar file of configuration files, and a small shell script to extract those files to the correct location.   Run the script and the configuration files will be restored.  

      Unfortunately, I can't remember if I made the /usr/bin/X script part of the tar file.  If not, let me know and I will post the contents of the script so you can restore it manually.


    • Dr Bill C Riemers

      Err.  Correction.  It it not that most of the options in the master configuration don't work.  Rather it is that the new format for the gdm configuration in Fedora 9 no-longer has an option for specifying the X server which should be used.

    • skeptical

      skeptical - 2008-10-21

      Thanks for the quick response, Bill; who better?

      My /root contains  no tar, just your, which I ran and now /usr/bin/X appears to be your custom script, not the original binary.  gdm doesn't fail any more, but nothing happens either, I guess since I'm not running any flavor of vnc, just xming.  Same with startx.

      Since I don't plan to use vnc, could you please outline a brief strategy of how to proceed? I guess I could start by editing the master conf (as soon as I locate it, there doesn't seem to be any gdm.conf).


      • Dr Bill C Riemers

        OK.  My memory must be failing me.  At least the script was there.  I haven't tried using gdm in Fedora 9 with coLinux.   According to what I found via google what you need is first to make sure you
        have the following version of gdm-2.22.0-10.fc9.  Next you need your /etc/gdm/custom.conf to be something like:

        # GDM configuration storage





        Then try booting to run level 5.  I'm not sure if the use of Xvnc effects the usability of xdmcp.   If xdmcp doesn't work, then you might try switching to Xvfb.  You should be able to install Xvfb with the command:

        yum install xorg-x11-server-Xvfb

        Just modify the name of /usr/bin/X script to point to Xvfb instead of Xvnc and reboot to run level 5 again.

        If that doesn't work I will have to try and scenario myself to have any further suggestions to offer.


    • skeptical

      skeptical - 2008-10-21

      gdm version is correct, made the changes to custom.conf but it still fails.  Installed Xvfb and changed your X script to launch it instead, still no good.

      Is it possible I'm missing some basic X setting that specifies the display's (i.e. xp's) network address?


    • skeptical

      skeptical - 2008-10-22

      As you indicated above, according to /etc/gdm/custom.conf doesn't support the daemon/KillInitClients or xdmcp/AllowRootLogin options any longer.  There isn't any [servers] section in the default (empty) custom.conf either, so likely the setting servers/0=inactive has no effect.

      Haven't found any info on where/how one might otherwise control these settings, though.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks