emerge perl hangs on lib/Benchmark

Help
2004-09-15
2013-05-09
  • Dan Wickstrom

    Dan Wickstrom - 2004-09-15

    I'm running the gentoo flavor of coLinux-0.5.1 on an HP nc8000 laptop and I've been running into alot of problems with emerges.

    when I do: emerge -uD system

    the emerge runs until the test portion of perl-5.8.4 and then it hangs with the processor load at 100% running perl.

    [snipped]

    lib/autouse..........................ok
    lib/base/t/base......................ok
    lib/base/t/fields-base...............ok
    lib/base/t/fields....................ok
    lib/Benchmark........................

    chost, cflags and USE are set as follows:

    CFLAGS="-march=pentium3 -pipe -O0 -funroll-loops"
    CHOST="i686-pc-linux-gnu"
    USE="X bitmap-fonts gif gtk gtk2 imlib java jpeg libg++ libwww mad mmx mpeg ncurses oggvorbis opengl pam perl pic pie png python qt readline
    sdl slang spell sse ssl tcpd truetype x86 xml2 xmms xprint xv zlib"

    I'm using -O0 optimzation, since I also ran into problems with assembler errors for some of the other packages that I've tried installing or updating. 

    My cpu is a pentium-M running at 1.5G Hz

    I've emerge'd the same version of perl on a desktop machine without any problems, so I think it's something specific to the coLinux installation.  Any ideas?

     
    • Android808

      Android808 - 2004-09-16

      I had the same problem.  If you watch the build process you may also fing that the HiRes time test also fails, in my case it was on test 19.

      I tried several fixes but in the end downloaded a different Gentoo image, its worked fine since.

       
    • Massimiliano Faralli

      download the last built man
      5.1 is a biit old

       
    • Dan Wickstrom

      Dan Wickstrom - 2004-09-17

      That was a typo, I meant 6.1. 

      When you went to a new image, did you use one of the 2.6 kernel versions?

      I did emerge -e world with optmizations set to -O0 and PIC and PIE added to the use flags, and it now seems that my assember problems have gone away as I'm able to compile with -O3.  The problem with building perl still persists however.

       
      • Android808

        Android808 - 2004-09-20

        I can't remember.  I run the 2.6 image for a while with no problems, but then bootmisc failed on boot.  After trying to rectify this issue I created my own 2004.2 image.  I think the problem was my system was full of masked packages as the 2.6 image allows ~x86.

         
    • Massimiliano Faralli

      mmmmm

      i've just reemerged perl and works

      look at the output.. maybe there is an error message

       
    • Dan Wickstrom

      Dan Wickstrom - 2004-09-21

      As everything else seems to work okay, and I don't feel like starting over, I've commented out make test in the perl ebuild and finished the emerge of the package.  Perl seems to work fine, so I'm going to leave it for now.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks