Colinux FC5 and udev

Help
accarien
2006-08-08
2013-05-09
  • accarien

    accarien - 2006-08-08

    Hello,
    i have downloaded colinux 0.6.4 and the fc5 image on proposed on sourceforge.

    at boot, i have a message telling me that udev is too old for the version of kernel.

    i have nevertheless installed kde and vncserver, and  could log in kde using vnc under XP.

    But since udev doesn't work, i can't use konsole or mount file systems.

    So i tried to follow the steps explained in the wiki (here : http://wiki.colinux.org/mediawiki/index.php/Fedora5MinimalInstall071 ) , but after uninstalling dmraid, yum uninstalled many packages as xorg, yum and many others.

    I continued to follow the tutorial, but initscripts didn't install because of dependencies problems (wrong kernel version and others i don't remember).

    So i started again using a new fedora image.
    I tried to change only udev using rpm and the option --nodeps.

    after reboot, udev seems to work fine, i resintalled kdebase and vncserver and xorg-fonts, but now, i can't connect to X using vnc anymore.

    Did someone manage to get work fc5 ?

    I don't know how to do

    Bye

     
    • aguspiza

      aguspiza - 2006-09-09

      I have updated the info check again at:

      http://wiki.colinux.org/wiki/Fedora5MinimalInstall071#udev

       
    • skeptical

      skeptical - 2006-09-20

      Hi aguspiza,

      I'm trying to fix udev using your notes (above).  I'm guessing that

      "I have used initrd, modules, symbols and vmlinux version 2.6.15 from http://www.henrynestler.com/colinux/testing/devel-2.6.15-hn/20060906/bin/"

      means:

      Leave the 0.6.4 daemons and linux.sys unchanged and (re)place in colinux 0.6.4 directory:
      - 'modules-2.6.15-co-0.7.1-hn17.tgz' renamed to 'vmlinux-modules.tar.gz'
      - 'initrd-0.7.1-hn17.gz' renamed to 'initrd.gz'
      - 'symbols-0.7.1-hn17.zip' unzipped.
      - 'vmlinux-0.7.1-hn17.zip' unzipped.

      but doing this crashes XP(SP2) just as the boot sequence starts to run in the colinux console (goes by too fast to see how far it gets). Could you spell out this step in a little more detail for the uninitiated?

      Like the user above my FC5+Gnome appeared to be running ok except for konsole, etc, and so I'm attempting to follow your procedure, starting from scratch with a fresh image.

      Also, I notice from http://www.henrynestler.com/colinux/testing/devel-2.6.15-hn/20060906/readme.txt:
      * Known bugs: ...
        - XP-SP2 stops with blue screen on boot

      Does this mean I'm out of luck?

      Thanks,
      Bahman

       
    • Bryan Ischo

      Bryan Ischo - 2007-03-08

      I "fixed" this by downloading a developer snapshot of the coLinux-0.8.0 release, which was built off of the 2.6.17 Linux kernel.  This kernel is new enough to support Fedora Core 5 properly and fixes the problems you are having.

      The snapshot I installed was the 20070302 snapshot.  It works well, but with a problem that I have found and posted a question to this forum about: the kernel modules do not include the kernel source from which they were built, and so you cannot build your own add-on kernel modules in this system.  I think this is an oversight on the part of the coLinux snapshot packager.

      However, if you don't intend to ever build kernel modules, the combination of coLinux-0.8.0 snapshot (using Linux kernel 2.6.17) and the Fedora Core 5 root image you got from sourceforge, works really really well!

       
    • Stefan "Bebbo" Franke

      To build your own kernel also get the source for the snapshot (http://www.colinux.org/snapshots/devel-colinux-20070302.tar.gz). Untar and make it.

      I already describe this here: https://sourceforge.net/forum/message.php?msg_id=4198357

      Bebbo

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks