Blue screen with XP SP2 (0.6.2 and 0.6.1)

  • christoph

    christoph - 2005-05-30

    Hi all,

    I tried to install coLinux on my WinXP/SP2 machine - without sucess, unfortunately. Hardware is: P4-640 at 3.2GHz, HT enabled, 1GB RAM. Behavior: System crashes at startup after installation. Right now, my guess is that it occurs when the driver 'linux.sys' is being loaded (Blue screen shows up with IRQL_NOT_LESS_OR_EQUAL and linux.sys as origin of the crash).
    System behaves the same if I try to load the driver manually ('colinux-daemon --install-driver).
    I've also tried to register colinux as a service. This was successfull, but I couldn't start colinux either ('net start colinux'). Response was something like 'manager: file not found'.

    I've already read about the PAE-stuff, but I was'nt able to figure it out. Anyway, since the topic seems to be related to big system with a large amount of RAM I suppose that doesn't apply to my pc.

    Any help would be most appreciated - thanx a lot.

    • Erik

      Erik - 2005-12-07

      I have the same issue here. I am running off a laptop (HP ZD8000) with 1.5gb ram. I have tried a great number of things to get CoLinux to work. Here is a list of what I have tried:
      Safe Mode - Rebooted to safe mode and started CoLinux. This appears to have worked to a point. The VNC never came up, but I found a terminal session can be established. This is great, except I have no internet access.

      msconfig - I have gone through several iterations and combinations of configurations for this machine in msconfig. Ended up completely disabling everything, but still received a bluescreen when CoLinux started.

      Device Profile - Created a separate device profile and attempted to disable devices on my system to determine which device/driver is causing the problem. Nothing.

      System Reinstall - Reinstalled my entire OS thinking that I had something horribly corrupted. It is Windows after all! But, much to my utter frustration and dismay, received the same blue screen with CoLinux.

      So, what do we do now? It sounds like Chris's idea about large RAM volume may be the problem. Is there a solution to this, or do I resort to partitioning my drive, installing Linux, and fighting with Wireless networking?

      • Nuno Lucas

        Nuno Lucas - 2005-12-08

        You need to turn off DEP support (the NX - No eXecute - SP2 support).
        Search the forums/mailing lists for how to do it.

        ~Nuno Lucas

    • Nathan True

      Nathan True - 2006-02-08

      Seconding this - my bluescreen was cured when I disabled my NX support (it was in my BIOS setup).


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks