Change the permissions for a USD HD

Help
adicm
2006-03-01
2013-05-09
  • adicm
    adicm
    2006-03-01

    Hi.  I'm running coLinux with the Latest Debain distribution and a Cygwin/x Session. I'm mounting a USB drive with fstab and as a Cofs (cofs0 /mnt/hde cofs rw,sync,user 0 0).  When I log in as a root, I have RW access to the files in this drive, but if I enter with other user, I only have RO access to this files.  I tried to change the permissions of a file logged in as root in KDE, but when I check the properties of the file it always return to User RW Other RO Group RO, no matter how many times I change it.  Can anybody please give me a hand with this??

     
    • try to give user id and group id when you mount the drive, or in fstab

      (from cofs.txt:)
      mount -t cofs cofs0:Share -o uid=dax,gid=dax,dmask=0700,fmask=0700 /mnt/windows

      (dax is the user that will own the drive)
      or in fstab

      cofs0 /mnt/hde cofs rw,sync,uid=dax,gid=dax 0 0

      specifying 'user' in the fstab entry allows a user to mount the drive, in which case he'd own it, I think. But if the drive is mounted at boot it'll be owned by root.

       
    • adicm
      adicm
      2006-03-02

      I'll try assign the user, but I was thinking about leave some folders RW for any user...  Well, I'll tell you how it works...

       
    • adicm
      adicm
      2006-03-02

      mmmm.... I was wonder... if I make that userx owns the drive... root can access with rw too?

       
    • adicm
      adicm
      2006-03-02

      I Just Can't, I login as root try chown and chmod, but I always get:

      drwxr-xr-x  1 root root    0 2002-10-28 13:03 hde

      I had try:

      chown -R userx:userx hde
      chmod -R a+rwx hde

      But neither the permissions or the owner and group change...  Any Idea??

       
    • Henry N.
      Henry N.
      2006-03-03

      Changing user or permision after mount have no effect. (non implement)

      cofs only works with 'flat' mode.  In this mode you have only one user:group and mode bits from mount option.

      To allow writes in some dubdirs and some others not, you can only handle it with different mounts in the destination and source tree, and different cofs drives.

      for sample in config
        cofs=C:\  cofs1=C:\Temp

      mount -o uid=hn,gid=users,fmask=0440,dmask=0555 -t cofs cofs0 /mnt/read_only

      mount -o uid=hn,gid=users,fmask=0660,dmask=0775 -t cofs cofs1 /mnt/can_write

      This options can also put into your fstab.

      Henry