MS Loopback adapter...

inky
2005-02-17
2013-05-09
  • inky

    inky - 2005-02-17

    Hi,

    I have installed coLinux with the Gentoo-colinux-stage3-x86-2004.3 image.

    It's up and running except I haven't yet managed to bring any form of networking  up and running successfully. I have a wireless network based on Linksys WG311T/DB834GT and I suspect that it is the lack of TCP/IP checksum disabling options (as per the wiki) which is stopping me.

    I have just passed my 90th reboot, it's 5:30 in the morning, it's my birthday and I'm tired :-).

    However...

    In the absence of a wireless network connection to the internet successfully barring me from doing an emerge --sync and picking up vi, I thought that it would at least be nice to see some packets flying about between Windows and coLinux. After reading the very interesting http://www.sklar.com/blog/index.php?/archives/55-Wrangling-CoLinux-Networking.html blog, I decided to try and get communication going using the loopback adapter. BTW, I have installed TAP, WinPCAP and the MS loopback adapter. My loopback adapter I have configured for static ip 192.68.0.100.

    My default.coLinux.xml looks like...
    <?xml version="1.0" encoding="UTF-8"?>
    <colinux>
        <block_device index="0" path="\DosDevices\D:\Program Files\coLinux\Gentoo-colinux-stage3-x86-2004.3"
        enabled="true" />
        <block_device index="1" path="\DosDevices\D:\Program Files\coLinux\swap_1024Mb"
        enabled="true" />
        <bootparams>root=/dev/cobd/0</bootparams>
        <initrd path="initrd.gz" />
        <image path="vmlinux" />
        <memory size="256" />
        <network index="0" type="bridged" name="Loopback" />
    </colinux>

    coLinux boots just fine with swap enabled.

    and my /etc/conf.d/net contains...
    iface_eth0="192.68.0.40 broadcast 192.68.0.255 netmask 255.255.255.0"
    gateway="eth0/192.68.0.1"

    Gentoo brings up the loopback adapter on boot but not the network - so I run
    /etc/init.d/net.eth0 start
    and ifconfig -a gives me:-
    * Bringing eth0 up (192.68.0.40)...                                      [ ok ]
    *   Setting default gateway (192.68.0.100)...                            [ ok ]
    eth0      Link encap:Ethernet  HWaddr 00:FF:54:70:00:00
              inet addr:192.68.0.40  Bcast:192.68.0.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:2

    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

    But I can't ping 192.68.0.100 from coLinux
    I can ping my own static ip 192.68.0.40 from coLinux
    Windows can't ping 192.68.0.40

    Incidentally, my wireless network with DHCP uses the address ranges 192.68.0.2-192.68.0.255 with 192.68.0.1 being the router itself and as the Windows box is ATM the only box up, it is sitting at 192.68.0.2

    From Windows, ipconfig /all gives:-

    Windows IP Configuration

            Host Name . . . . . . . . . . . . : boar
            Primary Dns Suffix  . . . . . . . :
            Node Type . . . . . . . . . . . . : Unknown
            IP Routing Enabled. . . . . . . . : No
            WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

            Media State . . . . . . . . . . . : Media disconnected
            Description . . . . . . . . . . . : VIA PCI 10/100Mb Fast Ethernet Adapter
            Physical Address. . . . . . . . . : 00-30-18-77-42-21

    Ethernet adapter Wireless Network Connection:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : NETGEAR 108 Mbps Wireless PCI Adapter WG311T
            Physical Address. . . . . . . . . : 00-0F-B5-22-7E-33
            Dhcp Enabled. . . . . . . . . . . : Yes
            Autoconfiguration Enabled . . . . : Yes
            IP Address. . . . . . . . . . . . : 192.68.0.2
            Subnet Mask . . . . . . . . . . . : 255.255.255.0
            Default Gateway . . . . . . . . . : 192.68.0.1
            DHCP Server . . . . . . . . . . . : 192.68.0.1
            DNS Servers . . . . . . . . . . . : 192.68.0.1
            Lease Obtained. . . . . . . . . . : 17 February 2005 04:03:46
            Lease Expires . . . . . . . . . . : 20 February 2005 04:03:46

    Ethernet adapter Bluetooth Network Connection:

            Media State . . . . . . . . . . . : Media disconnected
            Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network) #2
            Physical Address. . . . . . . . . : 00-02-72-03-08-8C

    Ethernet adapter Loopback:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : Microsoft Loopback Adapter
            Physical Address. . . . . . . . . : 02-00-4C-4F-4F-50
            Dhcp Enabled. . . . . . . . . . . : No
            IP Address. . . . . . . . . . . . : 192.68.0.100
            Subnet Mask . . . . . . . . . . . : 255.255.255.0
            Default Gateway . . . . . . . . . :

    Ethernet adapter TAP:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : TAP-Win32 Adapter V8 (coLinux)
            Physical Address. . . . . . . . . : 00-30-18-77-42-DB
            Dhcp Enabled. . . . . . . . . . . : Yes
            Autoconfiguration Enabled . . . . : Yes
            Autoconfiguration IP Address. . . : 169.254.49.143
            Subnet Mask . . . . . . . . . . . : 255.255.0.0
            Default Gateway . . . . . . . . . :

    Any ideas, please? I am at my (obviously lacking) wits end and I am going back to bed.

    Thanks in advance,

    Paul.

     
    • Massimiliano Faralli

      you can't use pcap networking with a wireless connection
      you need to use the tap way
      either with xp-bridge or with ics

      check on wiki

       
    • inky

      inky - 2005-02-17

      Sorry - perhaps I haven't made myself clear enough.

      In the absence of a wireless network connection to the internet successfully barring me from doing an emerge --sync and picking up vi, I thought that it would at least be nice to see some packets flying about between Windows and coLinux. After reading the very interesting http://www.sklar.com/blog/index.php?/archives/55-Wrangling-CoLinux-Networking.html blog, I decided to try and get communication going using the loopback adapter. BTW, I have installed TAP, WinPCAP and the MS loopback adapter. My loopback adapter I have configured for static ip 192.68.0.100.

      i.e., I am not even attempting to *consider* wireless networking ATM. I wish.

      I am using the Microsoft Loopback device.

      http://support.microsoft.com/kb/839013

      Paul.

       
    • inky

      inky - 2005-02-19

      OK, I found out why I can't connect to the MS Loopback  device in the WinPCAP RAQ...

      http://winpcap.polito.it/misc/faq.htm#Q-13

      I'll try something else...

      P.

       

Log in to post a comment.