Multiple Network Interfaces

2004-04-12
2004-05-18
  • Scott Tully

    Scott Tully - 2004-04-12

    I saw this in the notes for your 5.4 release.....

    "I also prepared the ground for supporting more than one network device
        (i.e, eth1, eth2, etc.), but it is not yet completed."

    Has any progress been made? I really, really, really would like to see this working.  I need a eth0 and a eth1.  Is there $omething i can do to help?

     
    • Roman

      Roman - 2004-04-13

      You can install more than one TAP adapter. Refer to OpenVPN for details.
      Than you can use more than one line in network adapters in xml file.
      The rest - to configure this adapters under linux

       
    • Josh Patterson

      Josh Patterson - 2004-04-23

      Is this only valid for tap, not bridged?

       
    • Martin Kanich

      Martin Kanich - 2004-04-26

      I think this didn't work. Did you really tried it?
      I used the latest snapshost 20040424_2 with net0=bridged, net1=tap and couldn't setup eth1 with debian-unstable. maybe i did something wrong.

       
      • lonemadmax

        lonemadmax - 2004-05-17

        You may need to tell the kernel to probe for that second device.  From the Linux BootPrompt- HowTo (11.1 Ethernet Devices):
        ------------------------------
        The most common use of this parameter is to force probing for a second ethercard, as the default is to only probe for one (with 2.4 and older kernels). This can be accomplished with a simple:

                ether=0,0,eth1

        Note that the values of zero for the IRQ and I/O base in the above example tell the driver(s) to autoprobe.
        ------------------------------

        So you may need to add that line to the kernel parameters.

        That said, I admit I haven't tried.

         
        • Martin Kanich

          Martin Kanich - 2004-05-18

          well, actually i read the source-code, so i'm quite sure it's not possible right now (well, with the last snapshot i had looking at :-). i had made a change to summon 2nd one at the boot time - didn't help, because of missing communication between module and 2nd daemon (i can't imagine why, but that doesn't matter right now :-( )

           

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks