Installing coLinux without admin rights ???

  • yohplala

    yohplala - 2007-10-13

    Hello all!

    I have found some posts concerning running coLinux without admin rights.
    I guess that to install and to run coLinux may be 2 distinct matters.
    While it may be possible to run coLinux without admin rights, would it be possible to install it in the same fashion?

    I have tried to install it on XP + SP2, without admin rights, without getting any error message. However, it does not seem to work...

    Here is my config file for coLinux 0.7.1 (adapted from a tutorial explaining how to install a ZenWalk in coLinux 0.6.x:\)

    # The default kernel

    # File contains the root file system.
    # Download and extract preconfigured file from SF "Images for 2.6".

    # 1 is the Zenwalk ISO we will be installing packages from

    # 2 is the temporary image we will be using during installation

    # Tell kernel the name of root device (mostly /dev/cobd0,
    # /dev/cobd/0 on Gentoo)
    # This parameter will be forward to Linux kernel.

    # Additional kernel parameters (ro = rootfs mount read only)

    # Maximal memory for linux guest

    Unfortunaltely, I get the following error message:

    Cooperative Linux Daemon, 0.7.1
    Compiled on Sat Jul 14 12:15:18 2007

    using 'L:\programs\coLinux\vmlinux' as kernel image
    configuring 96 MB of virtual RAM
    mapping cobd0 to \??\L:\programs\coLinux\zenwalk_fs
    mapping cobd1 to \??\L:\programs\coLinux\zenwalk-4.8.iso
    mapping cobd2 to \??\L:\programs\coLinux\initrd.img
    kernel boot parameters: 'root=/dev/cobd2 ro'

    colinux: manager open: last error: Le fichier spécifié est introuvable.

    daemon: exit code 8320a80e
    daemon: can't access CoLinuxDriver, please check status driver!

    A translation for the french sentence 'Le fichier spécifié est introuvable':
    'Unable to find the specified file'

    And here is the output obtained with a 'dir' command in L:\programs\coLinux\

    Répertoire de L:\programs\coLinux

    13/10/2007  10:18    <REP>          .
    13/10/2007  10:18    <REP>          ..
    12/10/2007  22:15             1,523 cmd.exe.lnk
    14/07/2007  14:15             3,140 cofs.txt
    14/07/2007  14:15            37,376 colinux-bridged-net-daemon.exe
    14/07/2007  14:15           267,776 colinux-console-fltk.exe
    14/07/2007  14:15            79,360 colinux-console-nt.exe
    14/07/2007  14:15            82,944 colinux-daemon.exe
    14/07/2007  14:15            14,747 colinux-daemon.txt
    14/07/2007  14:15            56,320 colinux-debug-daemon.exe
    14/07/2007  14:15            72,704 colinux-net-daemon.exe
    14/07/2007  14:15            50,688 colinux-serial-daemon.exe
    14/07/2007  14:15            88,576 colinux-slirp-net-daemon.exe
    14/07/2007  14:15             1,665 example.conf
    31/08/2006  23:46           415,873 initrd.gz
    30/09/2007  09:31        30,824,448 initrd.img
    30/09/2007  11:32        11,767,550 initrd.img.gz
    14/07/2007  14:15            69,120 linux.sys
    12/10/2007  22:59    <REP>          netdriver
    14/07/2007  14:15            23,732 NEWS.txt
    14/07/2007  14:15             9,090 README.txt
    12/10/2007  22:58            60,563 Uninstall.exe
    14/07/2007  14:13         2,914,109 vmlinux
    14/07/2007  14:15         1,075,409 vmlinux-modules.tar.gz
    12/10/2007  21:58       454,361,088 zenwalk-4.8.iso
    13/10/2007  10:05             1,879 zenwalk.conf
    12/10/2007  20:52     3,221,225,472 zenwalk_fs

    I do think there is no missing files. So I can't explain this error message:

    colinux: manager open: last error: Le fichier spécifié est introuvable.

    In addition, in the NEWS.txt file, I was reading:

      * TAP-Win32 device driver
        - version 8.4 update from openvpn-2.1_beta15a
        - usable without admin rights                                       <===
        - fixed crashing Vista
        - connection speed status 100 MBit/s (show/view only)
        - 'Check for truncated IPv4 packets' diabled
        - without linker debug symbols, without runtime debugging

    So is it possible to use the with admin rights, or not?
    Are there other coLinux components that do need admin rights to be installed/run ?

    I tried out the following command:

    colinux-daemon --install-driver

    and got of course the message:

    Cooperative Linux Daemon, 0.7.1
    Compiled on Sat Jul 14 12:15:18 2007

    access defined, not enough privileges

    So a last question:
    really no hope to install and to run coLinux without admin rights ??

    I thank you all for your time and answers.
    Best regards,


    • yohplala

      yohplala - 2007-10-25


      Well, I'm still in touch and welcome any comments concerning my post.
      Do you think installing coLinux without admin rights is a dream, or there could be a cross-cross-cross way to do it?

    • Henry N.

      Henry N. - 2007-11-01

      coLinux driver (linux.sys) and TAP driver can only install from an admin. Only admin has rights for installing any drivers.

      You can run coLinux and use the TAP without admin rights.

      Installing and running are different steps. If an "Admin" installs coLinux, then a non admin user can run it.

    • yohplala

      yohplala - 2007-11-02

      Thank you very much for your kindness to answer my post.
      I'm a little bit disappointed.
      However, if I may suggest an improvement of the current software: it may be to add a warning message when running the installer without admin rights.

      Still, good work to all who are contributing to coLinux!


    • yohplala

      yohplala - 2007-11-05


      Actually I come back to this thread as I have a suggestion/question.
      Using portable applications, I got the idea that may be an application could exist, setting up in Windows some kind of virtual registry, and so on... so that anyone without admin rights could still install/use any applications.
      I found THINSTALL. You may already know it.
      The matter is of course that the license is somewhat expensive...

      Could it be possible to work out some way to install/use coLinux in the same fashion?

      Right now, I think to try THINSTALL (there is a trial demo for 30 days).
      I found in Wikipedia that this solution is listed in the virtualization tools.
      It would be funny to use coLinux with a virtualization tool.



    • Henry N.

      Henry N. - 2007-11-06

      THINSTALL dosn't work with coLinux.

      The coLinux driver is an *hardware* driver, the supported 'hardware' is the CPU self. CoLinux needs the *full* access to the operating system and the CPU to switching into the the Linux operating system.

      Sorry, coLinux in on a simple software with accessing some files and registry only...

    • Henry N.

      Henry N. - 2007-11-06

      typofix :-(

      Sorry, coLinux is not a simple software with accessing some files and registry only...
      ... needs full CPU and RAM access.

      • yohplala

        yohplala - 2007-11-06


        Thanks for your reply!
        But still...
        (sorry for the following, I'm not an expert)
        ...if coLinux "only" needs full access to CPU and RAM, it is not as if it needs access to some protected programs.
        Am I wrong?

    • Henry N.

      Henry N. - 2007-11-08

      Shure, inside the Linux you are protected against Virus. But, your ask for browsing with IE on windows side, and this is the problem.

      An other Problem:
      The Linux under coLinux have no direct access to hardware. So, coLinux can't accessing the network (Ethernet LAN) without Windows. In other words, you must allow Windows the access to network to have the same access for coLinux. On one PC you can not block your windows (Internet Browser) to access the external LAN. Would you block your Windows from Internet access, then coLinux would also block (your Proxy idea).

      If you wish to surf in a save environemnt, you should run an Live CDROM, or install any oth the full virtualisations (VMware, VirtualBox).

      Why can't install without admin rights:
      The full CPU access means more as running applications, and more as running protected programs. CoLinux is an "hardware driver". This driver use some privilege CPU commands, which are not allowed from an application. THINSTALL don't allows to install hardware drivers.

      Linux and Windows runs on one CPU. But not at the same time. You starts (boots) Windows, and in the Windows you starts a Linux. Linux needs the full access to the CPU.

      At this point coLinux agents as cooperative switcher between Windows and Linux. The coLinux driver save all the registers from CPU, store the current (Windows) registers somether and clears the CPU. Than the coLinux driver loads the registers for Linux and runs the Linux. Loading and saveing all registers from a CPU needs privilege CPU commands.

      If you type a keystroke or yust receiving datas from internet (Ethernet LAN), the Linux can not handle it. The coLinux driver saves the current CPU state and loads the Windows side of registers, than it switched to Windows.

      If the Windows is "idle", or the task colinux can get a time slice of all Windows task, the coLinux driver would switching back into Linux again.

      This cyle goes permanetly, round about every 1 Millisecond and some time more often (more LAN traffic).

      The different from other virtualisations: coLinux allows Linux the same full CPU accessing as in native Linux. Full CPU and RAM is the "only" but big think, we need. coLinux reprograms the MCU (Memory Control Unit) to have the Linux typicaly virtual memory, with all the protections between Linux kernel space and user space. Seen from Windows side, this is a hard way and only allowed by "hardware drivers". Installing "hardware drivers" is per defauls only allowed for administrators.

    • yohplala

      yohplala - 2007-11-08


      Thank you very much.
      All you explained is quite understandable and I can say nothing more.
      Thanks a lot!

      Wish you success for the following!



Log in to post a comment.