#17 kernel driver exiting with -2147041265

closed-fixed
None
5
2005-02-18
2004-05-12
wouter_cx
No

When I start the daemon (version 0.6.0), it crashes
instantly. This is how it looks:

C:\Program Files\coLinux>colinux-daemon.exe -t nt -c
C:\Program Files\colinux\de
bian_default.colinux.xml
Cooperative Linux daemon
daemon: manager not opened
daemon: removing driver leftover
driver: stopping driver service
driver: removing driver service
daemon: installing kernel driver
daemon: error installing kernel driver: -2147041265

It also occurs when starting directly:
C:\Program Files\coLinux>colinux-daemon.exe

Discussion

  • wouter_cx

    wouter_cx - 2004-05-13

    Logged In: YES
    user_id=1040228

    problem was solved. Don't know what it was, probably:
    because of the space in the path to the config file
    C:\Program Files\colinux\de
    bian_default.colinux.xml
    the daemon couldn't load it.

     
  • wouter_cx

    wouter_cx - 2004-05-13
    • status: open --> closed
     
  • wouter_cx

    wouter_cx - 2004-05-13

    Logged In: YES
    user_id=1040228

    Error reproduced. If I start the daemon with:
    colinux-daemon.exe -t nt -c C:\
    colinux\debian_default.colinux.xml
    (There's a space after "C:\")
    I get the error -2147041265.

     
  • wouter_cx

    wouter_cx - 2004-05-13
    • status: closed --> closed-fixed
     
  • wouter_cx

    wouter_cx - 2004-05-13

    Logged In: YES
    user_id=1040228

    Probably the problem will be solved after a reboot.

     
  • wouter_cx

    wouter_cx - 2004-05-13

    Logged In: YES
    user_id=1040228

    This is not a bug of coLinux. I think it has something to do
    with strange behaviour of Windows:
    Whenever I go to the directory that contains the Debian
    image (1 GB large), explorer.exe freezes my computer. When I
    look in Task Manager, I see that explorer.exe is eating a lot of
    memory (23 MB sometimes). After that I set the priority of
    the process explorer.exe in Task Manager to low. After a
    while I can close the window again and Windows performance
    returns back to normal. But when I start colinux, the before
    mentioned error occurs.

    Solution to this problem: move the linux root image to a
    separate directory, for example root_fs, and change the
    config file accordingly.

     
  • wouter_cx

    wouter_cx - 2004-05-18

    Logged In: YES
    user_id=1040228

    I discovered that it's not because of a space in a filename.
    The problem has returned.

     
  • wouter_cx

    wouter_cx - 2004-05-18
    • status: closed-fixed --> open-fixed
     
  • wouter_cx

    wouter_cx - 2004-05-18

    Logged In: YES
    user_id=1040228

    By: alyandon
    (copied from the forum by wouter_cx)
    I have an idea. If you have your debian image file named
    something
    like debian.img
    then explorer might mistake it as a graphic file because of the
    extension and
    attempt to generate a thumbnail for it. Try renaming the file
    with a
    different
    extension.

     
  • Dan Aloni

    Dan Aloni - 2004-05-30
    • assigned_to: nobody --> da-x
     
  • George P Boutwell

    • status: open-fixed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks